follow ft86club on our blog, twitter or facebook.
FT86CLUB
Ft86Club
Speed By Design
Register Garage Members List Calendar Search Today's Posts Mark Forums Read

Go Back   Toyota GR86, 86, FR-S and Subaru BRZ Forum & Owners Community - FT86CLUB > Technical Topics > Forced Induction

Forced Induction Turbo, Supercharger, Methanol, Nitrous


User Tag List
go_a_way1

Reply
 
Thread Tools Search this Thread
Old 04-10-2022, 07:05 PM   #11145
BlOody_BoOger
Senior Member
 
BlOody_BoOger's Avatar
 
Join Date: May 2017
Drives: Hot lava FRS Monogram Charizard
Location: Sacramento Ca
Posts: 329
Thanks: 22
Thanked 85 Times in 63 Posts
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by Qwimby1 View Post
The throttle switch is working and the compressor is definitely turning, but apparently producing no boost and drawing no current. The meter is so dim it's hard to read except at night.


I have an uncomfortable theory that I hope is wrong. It occurred to me that by activating it with the ignition off and no engine vacuum, back pressure could have damaged the compressor. Does anyone have any thoughts about that? I can't find any possible leaks anywhere. Perhaps I can hook a boost gauge to it to learn more.



If it is a damaged compressor, does anyone know a place that could repair it?
I doubt starting it without the engine on was an issue I did that multiple times with my set up, and It never caused issues. Try turning it on with it completely off. Put the intake pipe back on leave everything hooked up and have the compressor off to the side and turn the compressor on with the engine running this way you don't completely drain it. And see if it's speeding up all the way.

Sent from my IN2017 using Tapatalk
BlOody_BoOger is offline   Reply With Quote
The Following User Says Thank You to BlOody_BoOger For This Useful Post:
Qwimby1 (04-10-2022)
Old 04-10-2022, 08:22 PM   #11146
Qwimby1
Senior Member
 
Join Date: Nov 2015
Drives: 14 FRS Monogram, 05 Mazdasped Miata
Location: Sarasota, FL
Posts: 571
Thanks: 133
Thanked 144 Times in 106 Posts
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by BlOody_BoOger View Post
I doubt starting it without the engine on was an issue I did that multiple times with my set up, and It never caused issues. Try turning it on with it completely off. Put the intake pipe back on leave everything hooked up and have the compressor off to the side and turn the compressor on with the engine running this way you don't completely drain it. And see if it's speeding up all the way.

Sent from my IN2017 using Tapatalk
Hey thanks. I'll try that. I think there's a thread here somewhere about that valve also.
Qwimby1 is offline   Reply With Quote
Old 04-10-2022, 08:37 PM   #11147
BlOody_BoOger
Senior Member
 
BlOody_BoOger's Avatar
 
Join Date: May 2017
Drives: Hot lava FRS Monogram Charizard
Location: Sacramento Ca
Posts: 329
Thanks: 22
Thanked 85 Times in 63 Posts
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by Qwimby1 View Post
Hey thanks. I'll try that. I think there's a thread here somewhere about that valve also.

Here you go

Sent from my IN2017 using Tapatalk
BlOody_BoOger is offline   Reply With Quote
The Following User Says Thank You to BlOody_BoOger For This Useful Post:
Qwimby1 (04-10-2022)
Old 04-17-2022, 02:14 PM   #11148
m111
Junior Member
 
Join Date: Apr 2015
Drives: black frs
Location: alabama
Posts: 6
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 1 Post(s)
Tagged: 2 Thread(s)
If anyone is interested I'm fixing to list my phantom supercharger 2.5 with proceed controller.
m111 is offline   Reply With Quote
Old 05-15-2022, 12:06 PM   #11149
Qwimby1
Senior Member
 
Join Date: Nov 2015
Drives: 14 FRS Monogram, 05 Mazdasped Miata
Location: Sarasota, FL
Posts: 571
Thanks: 133
Thanked 144 Times in 106 Posts
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
No boost

It quit boosting about a month ago and I didn't have time to go after the problem, which may well be that solenoid hose that was mentioned at the time. When that happened, I could get it to spin by activating the throttle switch with the engine off. Since I had no time to work on it, I switched it off and have driven it that way for a month. Now something else is happening. When I try to get it to spin with motor off, it only starts to spin for about a second and quits. Once it spun for about 3 seconds and quit. I'm showing 28.3 volts. I planned to take it to my wrench and let him find the boost leak, but now this new problem. Does anyone know what might be going on now?
Qwimby1 is offline   Reply With Quote
Old 05-16-2022, 04:50 PM   #11150
Qwimby1
Senior Member
 
Join Date: Nov 2015
Drives: 14 FRS Monogram, 05 Mazdasped Miata
Location: Sarasota, FL
Posts: 571
Thanks: 133
Thanked 144 Times in 106 Posts
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
I sure hope one of you guys with more knowledge of these has some info. I'm all out of ideas.
Qwimby1 is offline   Reply With Quote
Old 05-18-2022, 12:53 PM   #11151
Qwimby1
Senior Member
 
Join Date: Nov 2015
Drives: 14 FRS Monogram, 05 Mazdasped Miata
Location: Sarasota, FL
Posts: 571
Thanks: 133
Thanked 144 Times in 106 Posts
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
No boost, no spin

I unhooked the compressor enough to hand spin it and it seems to turn OK, although I can feel some resistance at certain points in the revolution. I think it was like that before I installed and it worked OK. When I activate the throttle switch it just starts to spin and quits. Volts drop from 28.3 to 25+ very briefly and then back to 28.3. I'm assuming the dump batteries are charged because of the voltage reading, but could it be that after no use for a month they have lost enough charge to create this problem? I drove it most of a month with the system turned off, but did have it on for a while. They should be getting a charge. It's getting a signal from the controller because it does try to spin for just a moment. I'm at a loss to figure it out.
Qwimby1 is offline   Reply With Quote
Old 05-18-2022, 02:42 PM   #11152
Tcoat
Senior Member
 
Tcoat's Avatar
 
Join Date: Jul 2014
Drives: 2020 Hakone
Location: London, Ont
Posts: 69,845
Thanks: 61,656
Thanked 108,286 Times in 46,456 Posts
Mentioned: 2495 Post(s)
Tagged: 50 Thread(s)
Quote:
Originally Posted by Qwimby1 View Post
I unhooked the compressor enough to hand spin it and it seems to turn OK, although I can feel some resistance at certain points in the revolution. I think it was like that before I installed and it worked OK. When I activate the throttle switch it just starts to spin and quits. Volts drop from 28.3 to 25+ very briefly and then back to 28.3. I'm assuming the dump batteries are charged because of the voltage reading, but could it be that after no use for a month they have lost enough charge to create this problem? I drove it most of a month with the system turned off, but did have it on for a while. They should be getting a charge. It's getting a signal from the controller because it does try to spin for just a moment. I'm at a loss to figure it out.
Start with confirming your level and charging system. I would never assume anything when it comes to batteries. Check you draw amperage. That has more meaning than volts.
__________________
Racecar spelled backwards is Racecar, because Racecar.
Tcoat is offline   Reply With Quote
The Following 2 Users Say Thank You to Tcoat For This Useful Post:
Qwimby1 (05-18-2022), Target70 (05-18-2022)
Old 05-18-2022, 03:17 PM   #11153
Qwimby1
Senior Member
 
Join Date: Nov 2015
Drives: 14 FRS Monogram, 05 Mazdasped Miata
Location: Sarasota, FL
Posts: 571
Thanks: 133
Thanked 144 Times in 106 Posts
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by Tcoat View Post
Start with confirming your level and charging system. I would never assume anything when it comes to batteries. Check you draw amperage. That has more meaning than volts.

Thanks, I'll make that my next step. Starter battery has 12.79. I have to take off some stuff to get to the dump batteries.
Qwimby1 is offline   Reply With Quote
Old 06-03-2022, 03:01 PM   #11154
Qwimby1
Senior Member
 
Join Date: Nov 2015
Drives: 14 FRS Monogram, 05 Mazdasped Miata
Location: Sarasota, FL
Posts: 571
Thanks: 133
Thanked 144 Times in 106 Posts
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
I finally had a chance to get in there and didn't have to look too far. One ETX16 dump battery is holding 12.83V, the other 11.77.


I'll order a new pair.
Qwimby1 is offline   Reply With Quote
Old 06-04-2022, 07:35 AM   #11155
WNDSRFR
Senior Member
 
Join Date: Jan 2014
Drives: FR-S,GTI
Location: Cocoa, Florida
Posts: 1,155
Thanks: 228
Thanked 824 Times in 419 Posts
Mentioned: 13 Post(s)
Tagged: 0 Thread(s)
It's almost always the batteries.
They only last a couple years but are pretty cheap. I change them every couple years regardless.
WNDSRFR is offline   Reply With Quote
The Following User Says Thank You to WNDSRFR For This Useful Post:
Qwimby1 (06-05-2022)
Old 06-04-2022, 07:35 AM   #11156
WNDSRFR
Senior Member
 
Join Date: Jan 2014
Drives: FR-S,GTI
Location: Cocoa, Florida
Posts: 1,155
Thanks: 228
Thanked 824 Times in 419 Posts
Mentioned: 13 Post(s)
Tagged: 0 Thread(s)
It's almost always the batteries.
They only last a couple years but are pretty cheap. I change them every couple years regardless.
WNDSRFR is offline   Reply With Quote
Old 06-04-2022, 07:46 AM   #11157
WNDSRFR
Senior Member
 
Join Date: Jan 2014
Drives: FR-S,GTI
Location: Cocoa, Florida
Posts: 1,155
Thanks: 228
Thanked 824 Times in 419 Posts
Mentioned: 13 Post(s)
Tagged: 0 Thread(s)
What battery tray are you using?
I still use the original 1.5 tray with the Powersonic batteries. About 40 bucks apiece.
WNDSRFR is offline   Reply With Quote
Old 06-04-2022, 07:46 AM   #11158
WNDSRFR
Senior Member
 
Join Date: Jan 2014
Drives: FR-S,GTI
Location: Cocoa, Florida
Posts: 1,155
Thanks: 228
Thanked 824 Times in 419 Posts
Mentioned: 13 Post(s)
Tagged: 0 Thread(s)
What battery tray are you using?
I still use the original 1.5 tray with the Powersonic batteries. About 40 bucks apiece.
WNDSRFR is offline   Reply With Quote
 
Reply

Tags
26$ / wtq, affordable boost, better than turbo, brz electric supercharger, do want, dumbass freddy, electric shrimpage, electric supercharger, electronic supercharger, epic thread tag, fanboy circle jerk!, freddy keyboardwarrior, frs electric supercharger, get a real blower, haters gonna hate, hows the battery life?, lol, moar powa, nos with battery, one gear race champion, only pulls hard once, phantom charge, pm-robftss to order!, release date=not yet, release it already!, released!, rice, shut up and take our $$$, snake oil claims, street only, super pursuit mode, the price isn't known yet, tq300 plzkkthxbai, wooshy noise, yes turbo is better, yes turbo is expensive

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Circuit Motorsports - Vortech Supercharger FR-S Build + Full Perrin Exhaust & Extras Circuit Motorsports Member's Car Journals 4 03-21-2013 04:45 PM
Subaru BRZ : Full Throttle, powerslide, hard revving & ride ESBjiujitsu BRZ Photos, Videos, Wallpapers, Gallery Forum 20 05-30-2012 06:43 PM
86 Full Throttle Video + another. Aus86 FR-S & 86 Photos, Videos, Wallpapers, Gallery Forum 2 04-02-2012 07:07 AM


All times are GMT -4. The time now is 03:49 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
User Alert System provided by Advanced User Tagging v3.3.0 (Lite) - vBulletin Mods & Addons Copyright © 2024 DragonByte Technologies Ltd.

Garage vBulletin Plugins by Drive Thru Online, Inc.