follow ft86club on our blog, twitter or facebook.
FT86CLUB
Ft86Club
Speed By Design
Register Garage Members List Calendar Search Today's Posts Mark Forums Read

Go Back   Toyota GR86, 86, FR-S and Subaru BRZ Forum - FT86CLUB > Technical Topics > Issues | Warranty | Recalls / TSB

Issues | Warranty | Recalls / TSB Problems, issues, recalls, TSBs


User Tag List

Reply
 
Thread Tools Search this Thread
Old 02-09-2021, 06:01 PM   #1
Jstyle
Member
 
Join Date: Jan 2021
Drives: 2020 86
Location: North VA
Posts: 68
Thanks: 8
Thanked 14 Times in 9 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Check engine light then a traction control light then just a check engine... and then

So I just picked up a 15 FRS on Saturday. Since picking it up, I’m finding a lot of little surprises. One is someone installed a remote starter in it, not sure that’s a good idea since it’s manual but I digress.

Some of the other problems have been: one of the lug nuts wasn’t tightened all the way down so the lug nut fell off at some point. Another lugnut was cross threaded so I need to replace the stud.

Then today I went out for a quick drive and I got a check engine light and a traction control light. The traction control light went out shortly there after so I’m hoping that was a fluke. Unfortunately Check Engine isn’t going away. Anyone have any insight on a traction control light that mysteriously comes on and goes away?

Sooooo.... I tried to pull out my old OBD2 scanner and it’s not working. Anyone have a specific scanner they like? I saw a few on Amazon just didn’t know if anyone had any experience. I have an iPhone so I cant have a Android only one... I’d prefer to have Bluetooth because wireless is a pain sometimes.
https://www.amazon.com/Bluetooth-Pro.../dp/B08FWRH32V
https://www.amazon.com/Veepeak-OBDCh.../dp/B073XKQQQW
Jstyle is offline   Reply With Quote
Old 02-09-2021, 06:52 PM   #2
Jstyle
Member
 
Join Date: Jan 2021
Drives: 2020 86
Location: North VA
Posts: 68
Thanks: 8
Thanked 14 Times in 9 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
So from my reading after I posted this... It seems like the sky is the limit on what could cause this until I have some codes.

One thing that I was thinking is that it wouldn’t be a cam gear issue though because I have a 2015. Or is that a false assumption.

Any thoughts or help would be much appreciated.
Jstyle is offline   Reply With Quote
Old 02-09-2021, 07:04 PM   #3
RToyo86
Senior Member
 
RToyo86's Avatar
 
Join Date: Mar 2018
Drives: 17 Asphalt 86
Location: Ottawa
Posts: 1,233
Thanks: 785
Thanked 1,014 Times in 570 Posts
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
I have the veepeak Bluetooth port.
Had it for a few years and use it regularly with the torque app. No issues.

Get the code pulled. No sense it playing the guessing game without more info.
RToyo86 is online now   Reply With Quote
Old 02-10-2021, 12:52 AM   #4
rbfr.s
Member
 
rbfr.s's Avatar
 
Join Date: Nov 2020
Drives: 2014 FR-S
Location: WA
Posts: 19
Thanks: 10
Thanked 26 Times in 9 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
A common engine code if the car is modified would be P0420. This pertains to the O2 sensors in your cats - specifically the header. If you have a header and the previous owner didn't tune the car, you can clear this code with an OBD2 and get out of limp mode. Like you said though, it's all speculation until you pull codes. I personally have Autel AutoLink AL319 OBD2 and it's covered all my basic tasks.
__________________
Professional Car Breaker
rbfr.s is offline   Reply With Quote
Old 02-12-2021, 10:05 AM   #5
Jstyle
Member
 
Join Date: Jan 2021
Drives: 2020 86
Location: North VA
Posts: 68
Thanks: 8
Thanked 14 Times in 9 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
So quite a laundry list of codes that I was able to pull this morning:
============1==============
P000B
Raw code: 000B
ECU: Engine control unit
Status: Confirmed
OBDII: Exhaust camshaft position B, bank 1 - slow response

============2==============
P000B
Raw code: 000B
ECU: Engine control unit #1
Status: Confirmed
OBDII: Exhaust camshaft position B, bank 1 - slow response

============3==============
C1201
Raw code: 5201
ECU: ABS control unit #2
Status: Confirmed
Toyota: Engine Control System Malfunction (VCS lamp ON-RX3) or ECM/TCM malfunction / 51

============4==============
C1231
Raw code: 5231
ECU: ABS control unit #2
Status: Confirmed
Toyota: Steering Angle Sensor Signal or Circuit malfunction (Progr.)

============5==============
C1241
Raw code: 5241
ECU: ABS control unit #2
Status: Confirmed
Toyota: IG Power Source Circuit (MR, Cel.)

============6==============
U0100
Raw code: C100
ECU: ABS control unit #2
Status: Confirmed
OBDII: Data bus, engine control module (ECM) A - no communication

============7==============
B1011
Raw code: 9011
ECU: BCM #1/Convenience systems
Status: Confirmed

============8==============
B1012
Raw code: 9012
ECU: BCM #1/Convenience systems
Status: Confirmed
OBDII: Diagnosis Sensor Unit

============9==============
B1013
Raw code: 9013
ECU: BCM #1/Convenience systems
Status: Confirmed

============10==============
B1014
Raw code: 9014
ECU: BCM #1/Convenience systems
Status: Confirmed

============11==============
B1410
Raw code: 9410
ECU: BCM #1/Convenience systems
Status: Confirmed

============12==============
U0100
Raw code: C100
ECU: BCM #1/Convenience systems
Status: Confirmed
OBDII: Data bus, engine control module (ECM) A - no communication
Jstyle is offline   Reply With Quote
Old 02-12-2021, 10:58 AM   #6
Tcoat
He who smelt it...
 
Tcoat's Avatar
 
Join Date: Jul 2014
Drives: 2020 Hakone
Location: London, Ont
Posts: 64,226
Thanks: 56,929
Thanked 95,856 Times in 41,881 Posts
Mentioned: 2314 Post(s)
Tagged: 50 Thread(s)
Quote:
Originally Posted by Jstyle View Post
So quite a laundry list of codes that I was able to pull this morning:
The remote starter could be messing with the bus. Certainly appears that way by the codes. You could also have some damage to the wiring hrness somplace.
I hate chasing electrical gremlins and wish you luck!
__________________
Racecar spelled backwards is Racecar, because Racecar.
Tcoat is online now   Reply With Quote
Old 02-12-2021, 11:16 AM   #7
Jstyle
Member
 
Join Date: Jan 2021
Drives: 2020 86
Location: North VA
Posts: 68
Thanks: 8
Thanked 14 Times in 9 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Yeah that remote start piece just makes me angry...
Jstyle is offline   Reply With Quote
Old 02-12-2021, 01:22 PM   #8
Jstyle
Member
 
Join Date: Jan 2021
Drives: 2020 86
Location: North VA
Posts: 68
Thanks: 8
Thanked 14 Times in 9 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
I've called around and the audio shop I talked to doesnt want to touch it. They dont want to unfck someone elses mess so I'm not sure what to do.
Jstyle is offline   Reply With Quote
Old 02-13-2021, 03:01 PM   #9
RZNT4R
Professional Mechanic
 
Join Date: Apr 2010
Drives: 2017 86 6MT Oceanic
Location: Quebec, Canada
Posts: 463
Thanks: 11
Thanked 329 Times in 197 Posts
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by Jstyle View Post
I've called around and the audio shop I talked to doesnt want to touch it. They dont want to unfck someone elses mess so I'm not sure what to do.
If you just picked up the car go back to where you bought and have them unfuck it. Remote starter aside, those timing slow reponse codes can get VERY expensive to fix.

Even if used they should still have to honor a basic legal warranty.

Quote:
There is no “cooling-off period” when you buy a used vehicle. But with any purchase you make, you are protected by the legal warranty. This is a level of quality and durability implied under the law in BC into every sales contract. The legal warranty applies regardless of whether the seller mentions it.
https://dialalaw.peopleslawschool.ca...-with-used-car
RZNT4R is offline   Reply With Quote
Old 02-14-2021, 09:36 AM   #10
Jstyle
Member
 
Join Date: Jan 2021
Drives: 2020 86
Location: North VA
Posts: 68
Thanks: 8
Thanked 14 Times in 9 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
The problem is that in Virginia, the only recourse is a 3 day cooling off period. Once that is up, and it was up on Tuesday of this past week... There is nothing more I can do.

The shop I took it to checked the cam gears and did a full tear down on it before I bought it. The main one they’re telling me to worry about is the top one so.... I just changed out the oil to 5w-30 and have it properly filled pulled the battery terminal. Hopefully that is enough to tip the scale and it’ll be ok. I’m also taking it to an audio shop to see if they can take a look at removing the remote starter.

——-Wish me luck
Jstyle is offline   Reply With Quote
Old 02-14-2021, 10:32 AM   #11
RZNT4R
Professional Mechanic
 
Join Date: Apr 2010
Drives: 2017 86 6MT Oceanic
Location: Quebec, Canada
Posts: 463
Thanks: 11
Thanked 329 Times in 197 Posts
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by Jstyle View Post
The problem is that in Virginia, the only recourse is a 3 day cooling off period. Once that is up, and it was up on Tuesday of this past week... There is nothing more I can do.

The shop I took it to checked the cam gears and did a full tear down on it before I bought it. The main one they’re telling me to worry about is the top one so.... I just changed out the oil to 5w-30 and have it properly filled pulled the battery terminal. Hopefully that is enough to tip the scale and it’ll be ok. I’m also taking it to an audio shop to see if they can take a look at removing the remote starter.

——-Wish me luck
Oh, va = virgina, I thought it was Vancouver lol, hence the link.

If the car was not explicitly sold "as is" with the necessary documents you may still have a recourse

https://www.google.com/url?sa=t&sour...EekVu0d3dYYG9h

But depending on what was done in that "full teardown" that was done before you bought it, the argument that someone else fucked it may stand. What the hell did they do, one does not simply "check the cam gears" on these engines.
RZNT4R is offline   Reply With Quote
Old 02-14-2021, 10:58 AM   #12
Jstyle
Member
 
Join Date: Jan 2021
Drives: 2020 86
Location: North VA
Posts: 68
Thanks: 8
Thanked 14 Times in 9 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Oh I get it... I was wondering. I have been to Vancouver a few times on my way to Whistler so I’ve at least been there I’ve also been up to Ottawa, Halifax and Montreal on business trips... Have you ever been out to iCar Mirabel? Got a chance to do an event up there and drive STi’s around the track in the snow.

Anywho... Yeah it was pretty explicit on the forms that it was sold as is. I thought I had my bases pretty covered by getting it looked at by a tuner shop that had literally 3 Twins being worked on. At some point when the ice stops falling from the sky, I’ll take it out and see where I’m at.
Jstyle is offline   Reply With Quote
Old 02-14-2021, 01:58 PM   #13
RZNT4R
Professional Mechanic
 
Join Date: Apr 2010
Drives: 2017 86 6MT Oceanic
Location: Quebec, Canada
Posts: 463
Thanks: 11
Thanked 329 Times in 197 Posts
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by Jstyle View Post
Have you ever been out to iCar Mirabel?
Can't say I've had the chance, as a 3 hour drive away, it's not exactly on my doorstep, and not many tracks in my neck of the woods.
RZNT4R is offline   Reply With Quote
Old 02-15-2021, 05:10 PM   #14
Jstyle
Member
 
Join Date: Jan 2021
Drives: 2020 86
Location: North VA
Posts: 68
Thanks: 8
Thanked 14 Times in 9 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
So I changed the oil out wiped the codes. Drove around for around 25-30 miles today with a mix of highway and city driving. I still have the bus codes and the ABS codes but the CEL never came on and the camshaft code never popped back up. At least catastrophic engine failure isnt immediately imminent, so gotta take the small victories.
Jstyle is offline   Reply With Quote
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Check engine light and Traction light on. ser1alchill3r Engine, Exhaust, Transmission 20 08-30-2020 03:57 AM
Check Engine light and Traction Control Light JeRM Issues | Warranty | Recalls / TSB 22 08-28-2020 10:35 PM
Help needed! Check engine light after weird traction lights. dillanp86 Engine, Exhaust, Transmission 3 12-08-2016 09:17 AM
Engine Check light, Traction Control light, cruise control light all on suddenly wqc3241 Software Tuning 2 01-10-2016 07:37 AM
First Check Engine Light and Traction control QFry Issues | Warranty | Recalls / TSB 26 10-04-2014 11:27 PM


All times are GMT -4. The time now is 06:06 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
User Alert System provided by Advanced User Tagging v3.3.0 (Lite) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.

Garage vBulletin Plugins by Drive Thru Online, Inc.