follow ft86club on our blog, twitter or facebook.
FT86CLUB
Ft86Club
Delicious Tuning
Register Garage Members List Calendar Search Today's Posts Mark Forums Read

Go Back   Toyota GR86, 86, FR-S and Subaru BRZ Forum - FT86CLUB > Technical Topics > Suspension | Chassis | Brakes -- Sponsored by 949 Racing

Suspension | Chassis | Brakes -- Sponsored by 949 Racing Relating to suspension, chassis, and brakes. Sponsored by 949 Racing.


User Tag List

Reply
 
Thread Tools Search this Thread
Old 05-28-2013, 01:29 PM   #1
fareastbrz
Member
 
Join Date: Apr 2013
Drives: WR Blue BRZ
Location: FWB, FL
Posts: 32
Thanks: 6
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Sway Bar Popping Sounds?

I've recently installed a 22 front and the 18/19 rear whiteline sways both with their whiteline endlinks and I am getting popping sounds from all around.
fareastbrz is offline   Reply With Quote
Old 05-28-2013, 01:35 PM   #2
DragynVyrus
Member
 
Join Date: Mar 2012
Drives: FRS, MR2
Location: Edmonton
Posts: 33
Thanks: 0
Thanked 8 Times in 7 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Never really heard of a popping sound from sway bars, but more of a clunk. Make sure everything is tight, and double check the end links, they like to spin the ball joint inside of them resulting in not being tight. With the car on the ground, see if you can grab the links and push/pull them and if you feel it popping/clunking something is loose.

Hopefully that helps
DragynVyrus is offline   Reply With Quote
Old 05-28-2013, 02:14 PM   #3
Ninjin
Senior Member
 
Ninjin's Avatar
 
Join Date: Jun 2012
Drives: SWP BRZ 6MT
Location: Phoenix, AZ
Posts: 876
Thanks: 415
Thanked 576 Times in 332 Posts
Mentioned: 144 Post(s)
Tagged: 0 Thread(s)
I had a couple issues with my Whiteline bar as well. Make sure that the end link joints on the front aren't binding. This can happen if the end links are set too short and the pivot joint can't move far enough for the sway bar's motion. The other issue I had was interference with the LCA. The Whiteline fsb isn't the same shape as stock and will impact the LCA if the end links are set too long.

Sent from my Nexus S using Tapatalk 2
Ninjin is offline   Reply With Quote
Old 05-28-2013, 02:15 PM   #4
fareastbrz
Member
 
Join Date: Apr 2013
Drives: WR Blue BRZ
Location: FWB, FL
Posts: 32
Thanks: 6
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by Ninjin View Post
I had a couple issues with my Whiteline bar as well. Make sure that the end link joints on the front aren't binding. This can happen if the end links are set too short and the pivot joint can't move far enough for the sway bar's motion. The other issue I had was interference with the LCA. The Whiteline fsb isn't the same shape as stock and will impact the LCA if the end links are set too long.

Sent from my Nexus S using Tapatalk 2
yeah thats what i noticed and was wondering if i should switch bars or endlinks because it comes really close to the LCA even at the shortest setting
fareastbrz is offline   Reply With Quote
The Following User Says Thank You to fareastbrz For This Useful Post:
euroshowoff (07-28-2013)
Old 05-28-2013, 02:27 PM   #5
SubieNate
Senior Member
 
SubieNate's Avatar
 
Join Date: Aug 2012
Drives: 2013 FR-S Ultramarine
Location: Temecula, CA
Posts: 959
Thanks: 288
Thanked 559 Times in 269 Posts
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Did you leave the mounts loose and tighten after you put the car on the ground?
SubieNate is offline   Reply With Quote
Old 05-28-2013, 03:00 PM   #6
GTB/ZR-1
Senior Member
 
GTB/ZR-1's Avatar
 
Join Date: Oct 2012
Drives: '13 FR-S Firestorm--let's mod!!!
Location: Central, FL
Posts: 1,185
Thanks: 309
Thanked 444 Times in 258 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Your factory links may be too long--mine are & it comes into contact with the body @ full lock.
__________________
* '13 Toyobaru P&L Turbo FR-S--SOLD
* '15 Z51 Vette--but new Z06/Z07 pending.
* '09 Nissan GT-R--gone, but not forgotten... 10.63 @ 131+ on streeties.
* '90 ZR-1 11.0 @ 130.2 & 11.2 @ 132.4 sprayed 120 shot.
GTB/ZR-1 is offline   Reply With Quote
Old 05-28-2013, 07:59 PM   #7
Ninjin
Senior Member
 
Ninjin's Avatar
 
Join Date: Jun 2012
Drives: SWP BRZ 6MT
Location: Phoenix, AZ
Posts: 876
Thanks: 415
Thanked 576 Times in 332 Posts
Mentioned: 144 Post(s)
Tagged: 0 Thread(s)
Disclaimer: I'm still learning all this stuff myself, so if I say something that's not right, please call me out on it. (Not that anyone on the Internet has reservations about doing that in the first place )

Quote:
Originally Posted by fareastbrz View Post
yeah thats what i noticed and was wondering if i should switch bars or endlinks because it comes really close to the LCA even at the shortest setting
Hmm, the shortest setting should give sufficient clearance, at the cost of other problems (endlink joint binding). I'm assuming here that you're on stock struts. Aftermarket coilovers may not have the swaybar mounts in exactly the same place.

Here are the guidelines I learned after messing around a lot with my Whiteline swaybar:
1. With the car off the ground and wheels off, set the endlinks as long as possible without the end of the swaybar hitting the lower control arm. Make sure both endlinks are the same length. Do not tighten the endlinks at this time.

2. With the car fully resting on the ground (i.e. suspension is at normal ride height), check to see if the endlink bolts are both roughly parallel to the ground. If one or both of the joints are too close to their maximum range of motion at normal ride height, then the endlinks could bind in either compression or droop. This is bad because it causes noise, inconsistent handling behavior and potentially, endlink failure. This is a bit challenging on stock struts, since their endlink mounting bracket is angled ~45, and it took me some trial and error to figure out what was "close enough" to parallel to not cause any noise.

3. Tighten the endlinks and go for a drive! I found a long-handled wrench was helpful in getting the nuts tight enough, but I'm not exactly built like Thor.

4. Repeat as necessary. I don't understand why some folks on the Internet say that aftermarket bars "just make noise" and you have to accept it. I have yet to met someone IRL who thinks it is okay. Noise usually means that something is behaving badly.
Ninjin is offline   Reply With Quote
The Following User Says Thank You to Ninjin For This Useful Post:
danthedirt (06-04-2013)
Old 06-04-2013, 10:23 AM   #8
engee
Senior Member
 
Join Date: Mar 2012
Drives: Subaru
Location: NJ
Posts: 478
Thanks: 49
Thanked 146 Times in 90 Posts
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
I'm having the same issues. I re-tightened everything and the noise went away.

In the past couple of days, the noise is back. Anybody have thoughts?

engee is offline   Reply With Quote
Old 06-23-2013, 03:06 AM   #9
qoncept
Senior Member
 
qoncept's Avatar
 
Join Date: May 2013
Drives: 2013 BRZ
Location: Iowa
Posts: 928
Thanks: 135
Thanked 297 Times in 202 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Garage
Just installed my 22mm whiteline today and I've been fighting for 8 hours trying to get the clunk to go away. It clunks easy to much to live with. How are you people tightening the endinks with the car on the ground? I can't get anywhere near them.
__________________
qoncept is offline   Reply With Quote
Old 06-23-2013, 05:33 AM   #10
YDNA
Senior Member
 
YDNA's Avatar
 
Join Date: Jan 2013
Drives: Raven FR-S
Location: Orange County
Posts: 439
Thanks: 93
Thanked 167 Times in 94 Posts
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
http://www.ft86club.com/forums/showp...4&postcount=25
YDNA is offline   Reply With Quote
The Following User Says Thank You to YDNA For This Useful Post:
GTB/ZR-1 (06-25-2013)
Old 06-23-2013, 10:28 AM   #11
Hawaiian
That guy
 
Hawaiian's Avatar
 
Join Date: Feb 2012
Drives: Ultramarine mt FR-S
Location: chicago
Posts: 2,370
Thanks: 692
Thanked 1,385 Times in 730 Posts
Mentioned: 71 Post(s)
Tagged: 0 Thread(s)
My sway was making noise, but it turns out one of the nuts on the endlink was loose. I tightened it back up and everything is silent now.
__________________
Ultramarine mt FR-S
P&L stage 1 turbo
Prime Motoring Flex fuel
Jr Tuned 506whp @17psi (e73)
Hawaiian is offline   Reply With Quote
Old 06-24-2013, 04:56 PM   #12
qoncept
Senior Member
 
qoncept's Avatar
 
Join Date: May 2013
Drives: 2013 BRZ
Location: Iowa
Posts: 928
Thanks: 135
Thanked 297 Times in 202 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Garage
Ok, my endlinks (and sway bar) are definitely NOT hitting anything and they aren't lose. So I'm almost positive the endlinks are binding. So... how do you adjust them with the car on the ground?
__________________
qoncept is offline   Reply With Quote
Old 06-24-2013, 08:17 PM   #13
Rougenite
Senior Member
 
Rougenite's Avatar
 
Join Date: Dec 2012
Drives: Raven FR-S
Location: San Antonio, Texas
Posts: 286
Thanks: 17
Thanked 36 Times in 30 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Well, havent looked at the sway bar for the FR-S yet, but I had an issue with my tC and the 'pop'

There should be some rubber bushings where the sway is connected to the car, put a little while lithium grease in there.

Other than that, it should be your endlinks.

It is possible to have a completely silent aftermarket bar, just gotta work at it a little more!
Rougenite is offline   Reply With Quote
Old 06-24-2013, 11:09 PM   #14
whataboutbob
AutoX-10/10ths every run
 
whataboutbob's Avatar
 
Join Date: Jun 2012
Drives: 2013 Scion FR-S AT Firestorm
Location: San Marcos, CA, USA
Posts: 2,189
Thanks: 4,015
Thanked 1,521 Times in 818 Posts
Mentioned: 73 Post(s)
Tagged: 0 Thread(s)
Garage
I ended up running 3/8 washers on both sides of the sway bar where the end links connect. My car was also making clunking noises. No noises at all now. Also make sure everything is tight (i.e. endlink bolts, lock nuts for adjustment on end links if you have them).
whataboutbob is offline   Reply With Quote
The Following 2 Users Say Thank You to whataboutbob For This Useful Post:
supramkivtt2jz (04-25-2014), Trap63 (06-06-2014)
 
Reply

Tags
brace, endlink, suspension, swaybar, whiteline

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Loud popping in the intake Yruyur Engine, Exhaust, Transmission 72 02-22-2015 02:11 PM
foot rest popping noise abutterman Issues | Warranty | Recalls / TSB 34 02-20-2014 11:56 PM
Anyone heard any loud popping? Kimsey47 Subaru BRZ General Forum 103 07-30-2013 09:27 PM
BRZ gas pedal popping/squeaking noise chenshuo Issues | Warranty | Recalls / TSB 8 05-10-2013 09:52 AM
The number 86 popping up everywhere.. CSSM Off-Topic Lounge 19 06-19-2012 11:15 AM


All times are GMT -4. The time now is 09:20 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
User Alert System provided by Advanced User Tagging v3.3.0 (Lite) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Garage vBulletin Plugins by Drive Thru Online, Inc.