follow ft86club on our blog, twitter or facebook.
FT86CLUB
Ft86Club
86WORX
Register Garage Members List Calendar Search Today's Posts Mark Forums Read

Go Back   Toyota GR86, 86, FR-S and Subaru BRZ Forum & Owners Community - FT86CLUB > Technical Topics > Electronics | Audio | NAV | Infotainment

Electronics | Audio | NAV | Infotainment Anything related to in-car electronics, navigation, and infotainment.


User Tag List

Reply
 
Thread Tools Search this Thread
Old 09-02-2021, 11:39 AM   #1
SportyTaco86
Member
 
SportyTaco86's Avatar
 
Join Date: Sep 2021
Drives: 2013 Scion FRS, 2012 Tacoma
Location: FL
Posts: 16
Thanks: 3
Thanked 19 Times in 10 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Turn signal issue/question

I just picked up my FRS last week and noticed an issue with the turn signals right off the bat. When I first hit the switch (right or left) the indicator and signals come on but don't flash. If I turn the wheel slightly they will start flashing. This happens if the wheel is straight, or even if the wheel is already turned. Would this be a clockspring issue? Maybe the flasher relay (seems less likely)?

The PO had every cheap LED imaginable installed on the car, so I replaced all of the bulbs with OE replacements and it didn't resolve the issue.

I believe I had something similar happen with a 2004 Forester I owned a while back and there was a cup inside the steering column I had to replace.
SportyTaco86 is offline   Reply With Quote
Old 09-02-2021, 02:52 PM   #2
LimitedSlip
Senior Citizen Member
 
LimitedSlip's Avatar
 
Join Date: Jul 2018
Drives: Then-1977 Celica GT Now-2017 860SE
Location: In A Galaxy Far Far Away
Posts: 330
Thanks: 108
Thanked 313 Times in 171 Posts
Mentioned: 11 Post(s)
Tagged: 1 Thread(s)
Welcome to the forum SportyTaco86! There are a couple of third-party turn signal relay replacements that can be programmed to flash in various patterns. They are fairly common and an easy plug-and-play mod. But sometimes prone to problems. Maybe verify if you have an original factory relay or an aftermarket and is it working correctly? I agree, not as likely, but fairly easy to check.
LimitedSlip is offline   Reply With Quote
Old 09-02-2021, 03:48 PM   #3
SportyTaco86
Member
 
SportyTaco86's Avatar
 
Join Date: Sep 2021
Drives: 2013 Scion FRS, 2012 Tacoma
Location: FL
Posts: 16
Thanks: 3
Thanked 19 Times in 10 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by LimitedSlip View Post
Welcome to the forum SportyTaco86! There are a couple of third-party turn signal relay replacements that can be programmed to flash in various patterns. They are fairly common and an easy plug-and-play mod. But sometimes prone to problems. Maybe verify if you have an original factory relay or an aftermarket and is it working correctly? I agree, not as likely, but fairly easy to check.
Thanks! I'll take a look and see what I'm dealing with.
SportyTaco86 is offline   Reply With Quote
Old 09-02-2021, 03:57 PM   #4
SportyTaco86
Member
 
SportyTaco86's Avatar
 
Join Date: Sep 2021
Drives: 2013 Scion FRS, 2012 Tacoma
Location: FL
Posts: 16
Thanks: 3
Thanked 19 Times in 10 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by LimitedSlip View Post
Welcome to the forum SportyTaco86! There are a couple of third-party turn signal relay replacements that can be programmed to flash in various patterns. They are fairly common and an easy plug-and-play mod. But sometimes prone to problems. Maybe verify if you have an original factory relay or an aftermarket and is it working correctly? I agree, not as likely, but fairly easy to check.
Really good call! I looked under the dash and the OEM relay was still in place, but the harness was plugged into an LED relay that was left dangling under the column. That seems to have corrected the issue. I won't know for sure until I can take it for a spin later.

On another note, I've been dealing with a hyperflash issue on my Tacoma since installing aftermarket headlights (haven't had the time or motivation to add load equalizers), so maybe the LED relay will fit the Taco.
SportyTaco86 is offline   Reply With Quote
Old 09-02-2021, 10:33 PM   #5
soundman98
threadwrecker
 
soundman98's Avatar
 
Join Date: Sep 2013
Drives: 14 BRZ 'Ranger', 18 Tacoma 4Dr LB
Location: chicago-ish
Posts: 7,778
Thanks: 23,139
Thanked 9,202 Times in 4,597 Posts
Mentioned: 78 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by SportyTaco86 View Post
Really good call! I looked under the dash and the OEM relay was still in place, but the harness was plugged into an LED relay that was left dangling under the column. That seems to have corrected the issue. I won't know for sure until I can take it for a spin later.

On another note, I've been dealing with a hyperflash issue on my Tacoma since installing aftermarket headlights (haven't had the time or motivation to add load equalizers), so maybe the LED relay will fit the Taco.
according to this:
https://www.diodedynamics.com/led-fl...ta-tacoma.html

it's functionality is going to depend on if you have DTRL on your truck

looks like there's some big threads on tacomaworld on this as well
__________________
"The time you enjoy wasting is not wasted time"
soundman98 is offline   Reply With Quote
Old 09-03-2021, 08:58 AM   #6
SportyTaco86
Member
 
SportyTaco86's Avatar
 
Join Date: Sep 2021
Drives: 2013 Scion FRS, 2012 Tacoma
Location: FL
Posts: 16
Thanks: 3
Thanked 19 Times in 10 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by soundman98 View Post
according to this:
https://www.diodedynamics.com/led-fl...ta-tacoma.html

it's functionality is going to depend on if you have DTRL on your truck

looks like there's some big threads on tacomaworld on this as well
Thanks! I saw that as well. I do have DTRLs. Of course, the relay malfunctioning is what led to the creation of this thread, so I'll be throwing on some load equalizers instead. I'm 99% sure I have a few sets in the garage from motorcycle builds I've done in the past.
SportyTaco86 is offline   Reply With Quote
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn signal cancelling/turn off issue Koi Issues | Warranty | Recalls / TSB 5 10-18-2020 11:19 PM
TOMs & turn signal issue Powered By Jay Cosmetic Modification (Interior/Exterior/Lighting) 19 01-15-2015 12:33 AM
OLM turn signal switchback issue Scavanger Scion FR-S / Toyota 86 GT86 General Forum 5 09-17-2014 12:42 PM
LED Turn Signal Issue FR-S Matt Cosmetic Modification (Interior/Exterior/Lighting) 15 07-23-2013 01:47 PM
Turn signal issue Asphaltfrs1 Issues | Warranty | Recalls / TSB 3 06-21-2013 07:06 PM


All times are GMT -4. The time now is 10:27 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
User Alert System provided by Advanced User Tagging v3.3.0 (Lite) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.

Garage vBulletin Plugins by Drive Thru Online, Inc.