follow ft86club on our blog, twitter or facebook.
FT86CLUB
Ft86Club
Delicious Tuning
Register Garage Members List Calendar Search Today's Posts Mark Forums Read

Go Back   Toyota GR86, 86, FR-S and Subaru BRZ Forum & Owners Community - FT86CLUB > 1st Gens: Scion FR-S / Toyota 86 / Subaru BRZ > BRZ First-Gen (2012+) -- General Topics

BRZ First-Gen (2012+) -- General Topics All discussions about the first-gen Subaru BRZ coupe


User Tag List

Reply
 
Thread Tools Search this Thread
Old 09-13-2014, 12:47 PM   #1
Andy1814
Junior Member
 
Join Date: Sep 2014
Drives: 2013 BR-Z
Location: California
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
2013 Subaru BRZ, CEL on with no issues

Hi guys, I'm new to the forums.

So I parked my BR-Z inside my garage yesterday and everything was fine, no issues. The later on in the day I went in my car to get my phone I thought I should checked a couple of things. What happened was I put the key in the "on" position and for some reason the check engine light is on, and the radiator fans started to come on briefly and then stop and come on again. I have no idea what is going on here is some information that could help:

It is a 2013 Premium BRZ with 10,000 miles, I check fan relays and replaced them with spares I had. The idle is okay, car drives fine, and their are no known issues besides the CEL, and the fans coming on in the "on" position. I checked if the fans inside the car are on or the A/C and it is not.

Hopefully someone can help me out here!
Andy1814 is offline   Reply With Quote
Old 09-13-2014, 04:04 PM   #2
ashtray
As Seen On The Internet
 
Join Date: Apr 2011
Drives: 2003 WRX, 2013 BRZ, 442
Location: SoCal
Posts: 852
Thanks: 23
Thanked 251 Times in 159 Posts
Mentioned: 1 Post(s)
Tagged: 2 Thread(s)
Sounds like a dealer trip if you don't have anything to read the code.
ashtray is offline   Reply With Quote
Old 09-13-2014, 04:05 PM   #3
carbonBLUE
Reverse Burnouts
 
Join Date: Oct 2011
Drives: 2013 Argento FRS
Location: dallas!!!
Posts: 2,894
Thanks: 707
Thanked 1,257 Times in 592 Posts
Mentioned: 30 Post(s)
Tagged: 1 Thread(s)
Quote:
Originally Posted by Andy1814 View Post
Hi guys, I'm new to the forums.

So I parked my BR-Z inside my garage yesterday and everything was fine, no issues. The later on in the day I went in my car to get my phone I thought I should checked a couple of things. What happened was I put the key in the "on" position and for some reason the check engine light is on, and the radiator fans started to come on briefly and then stop and come on again. I have no idea what is going on here is some information that could help:

It is a 2013 Premium BRZ with 10,000 miles, I check fan relays and replaced them with spares I had. The idle is okay, car drives fine, and their are no known issues besides the CEL, and the fans coming on in the "on" position. I checked if the fans inside the car are on or the A/C and it is not.

Hopefully someone can help me out here!
Did you even start the car? CEL will appear if the engine isnt on. like every car on the planet.

also if your coolant temp is hot enough and your car is in the "on" position the fans will turn on to regulate the heat. Like every car on the planet, regardless if the engine is running or not
__________________

2000 Carbon Blue Toyota Celica GTS 152000 miles
(wont forget you)
2013 Argento Scion FR-S
2011 Infiniti G37x
carbonBLUE is offline   Reply With Quote
The Following User Says Thank You to carbonBLUE For This Useful Post:
B-R-Z (09-13-2014)
Old 09-13-2014, 04:06 PM   #4
B-R-Z
I love peanut butter
 
B-R-Z's Avatar
 
Join Date: Jun 2013
Drives: 2013 SWP BRZ Limited
Location: NJ
Posts: 1,598
Thanks: 428
Thanked 582 Times in 349 Posts
Mentioned: 14 Post(s)
Tagged: 2 Thread(s)
Garage
Buy a obd2 Bluetooth adapter and buy the torque app to read the code. $13 total.
B-R-Z is offline   Reply With Quote
Old 09-13-2014, 04:15 PM   #5
jflogerzi
Senior Member
 
jflogerzi's Avatar
 
Join Date: May 2012
Drives: 2013 Series 10 6MT FR-S
Location: Moreno Valley, CA
Posts: 5,251
Thanks: 1,870
Thanked 1,859 Times in 1,360 Posts
Mentioned: 70 Post(s)
Tagged: 0 Thread(s)
Garage
Quote:
Originally Posted by B-R-Z View Post
Buy a obd2 Bluetooth adapter and buy the torque app to read the code. $13 total.
+1 and read the code.
jflogerzi is offline   Reply With Quote
Old 09-13-2014, 06:52 PM   #6
Rota
Senior Member
 
Rota's Avatar
 
Join Date: Dec 2013
Drives: 2015 Series.Blue BRZ
Location: Chandler, AZ
Posts: 100
Thanks: 97
Thanked 63 Times in 37 Posts
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
If you don't want to buy a reader, AutoZone will check your codes for you for free.
Rota is offline   Reply With Quote
Old 09-14-2014, 01:18 AM   #7
Gords_zenith
Senior Member
 
Gords_zenith's Avatar
 
Join Date: Nov 2012
Drives: WRB BRZ Sport Tech
Location: Durham, Canada
Posts: 352
Thanks: 174
Thanked 110 Times in 64 Posts
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by carbonBLUE View Post
Did you even start the car? CEL will appear if the engine isnt on. like every car on the planet.

also if your coolant temp is hot enough and your car is in the "on" position the fans will turn on to regulate the heat. Like every car on the planet, regardless if the engine is running or not
^this. Why is this something new??
Gords_zenith is offline   Reply With Quote
 
Reply

Tags
brz, cel, cooling fan, issue, problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
subaru dealer 1st oil change free? and other issues DarkestBuddha BRZ First-Gen (2012+) -- General Topics 19 09-23-2013 02:17 AM
iOS6 + Subaru BRZ bluetooth issues Laika Electronics | Audio | NAV | Infotainment 9 11-20-2012 02:48 PM
Subaru looking into issues with the Nav TSY Issues | Warranty | Recalls / TSB 44 10-04-2012 11:43 AM
Any issues with Subaru engine? CyberFormula Engine, Exhaust, Transmission 10 06-26-2010 05:02 PM


All times are GMT -4. The time now is 09:53 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
User Alert System provided by Advanced User Tagging v3.3.0 (Lite) - vBulletin Mods & Addons Copyright © 2022 DragonByte Technologies Ltd.

Garage vBulletin Plugins by Drive Thru Online, Inc.