follow ft86club on our blog, twitter or facebook.
FT86CLUB
Ft86Club
Speed By Design
Register Garage Members List Calendar Search Today's Posts Mark Forums Read

Go Back   Scion FR-S Forum | Subaru BRZ Forum | Toyota 86 GT 86 Forum | AS1 Forum - FT86CLUB > Technical Topics > Suspension | Chassis | Brakes -- Sponsored by 949 Racing

Suspension | Chassis | Brakes -- Sponsored by 949 Racing Relating to suspension, chassis, and brakes. Sponsored by 949 Racing.


User Tag List

Reply
 
Thread Tools Search this Thread
Old 07-06-2019, 04:39 AM   #1
kev0
AUTOMATIC TRANNY
 
Join Date: Feb 2018
Drives: 2014 FRS AT
Location: Chicago, IL
Posts: 188
Thanks: 122
Thanked 20 Times in 17 Posts
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Brakes feel extremely hard after supercharger install

Flashed my car with the base Moto East tune. Had Sprintex 210 kit installed. I haven't been in the car for 7 days since it was out of service for the install (replacement parts took a while to come).

The first time I tried to step on the brakes, before I start the car, it was extremely firm and took a lot of pressure to depress the brake pedal. What the hell happened? Did I somehow get air in my brake lines or something? Car has not been driven for those 7 days!

I also have ABS and TC light on.
kev0 is offline   Reply With Quote
Old 07-06-2019, 08:21 AM   #2
Yoshoobaroo
Torque BuffaloChicken Dip
 
Yoshoobaroo's Avatar
 
Join Date: Mar 2016
Drives: 2013 BRZ
Location: Florida
Posts: 1,282
Thanks: 611
Thanked 876 Times in 490 Posts
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Garage
Is your supercharger feeding the brake booster pressurized air? Your bypass valve may not be working right. Check your manifold pressure when off the gas, it should be in vacuum.
__________________
Yoshoobaroo is offline   Reply With Quote
Old 07-06-2019, 10:44 AM   #3
maslin
Benz Tech
 
Join Date: Dec 2018
Drives: 2017 BRZ Premium
Location: Oregon
Posts: 516
Thanks: 281
Thanked 483 Times in 268 Posts
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by kev0 View Post
Flashed my car with the base Moto East tune. Had Sprintex 210 kit installed. I haven't been in the car for 7 days since it was out of service for the install (replacement parts took a while to come).

The first time I tried to step on the brakes, before I start the car, it was extremely firm and took a lot of pressure to depress the brake pedal. What the hell happened? Did I somehow get air in my brake lines or something? Car has not been driven for those 7 days!

I also have ABS and TC light on.
The engine only makes vacuum when it’s running. The booster will store a bit, usually a few presses and then the brakes will be hard.

Assuming all that came apart for the supercharger install the vacuum would have bled off. No vacuum in the booster = manual brakes.

Start the car, are the brakes normal? Then it’s all good. You’ll need scanner for the lights.
maslin is offline   Reply With Quote
The Following User Says Thank You to maslin For This Useful Post:
wparsons (07-09-2019)
Old 07-06-2019, 01:01 PM   #4
soundman98
Boost is Whack. N/A4LYFE
 
soundman98's Avatar
 
Join Date: Sep 2013
Drives: '14 brz limited
Location: chicagolandia
Posts: 1,577
Thanks: 2,058
Thanked 940 Times in 596 Posts
Mentioned: 11 Post(s)
Tagged: 0 Thread(s)
Another thread, same issues. Time to admit you brought it to the wrong shop and find a different shop to fix everything the first shop screwed up
__________________
my '14 brz limited "the return to normal" (or is it?)
led mods-10%(planning/designing/sitting on hands)audio mods-99%(done is never done)

hidplanet build log
soundman98 is offline   Reply With Quote
The Following User Says Thank You to soundman98 For This Useful Post:
wparsons (07-09-2019)
Old 07-06-2019, 01:22 PM   #5
86TOYO2k17
Senior Member
 
Join Date: Jan 2018
Drives: 2017 toyota 86
Location: PNW
Posts: 624
Thanks: 45
Thanked 243 Times in 175 Posts
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by kev0 View Post
Flashed my car with the base Moto East tune. Had Sprintex 210 kit installed. I haven't been in the car for 7 days since it was out of service for the install (replacement parts took a while to come).

The first time I tried to step on the brakes, before I start the car, it was extremely firm and took a lot of pressure to depress the brake pedal. What the hell happened? Did I somehow get air in my brake lines or something? Car has not been driven for those 7 days!

I also have ABS and TC light on.
Did you pull the brake booster hose cap off your old manifold and reinstall on back of supercharger manifold brake booster port? Are you running the brake booster to the engine without the check valve? Autos run brake booster to the engine with no check valve, and thus the brake booster port on back of manifold needs to be capped.
86TOYO2k17 is offline   Reply With Quote
The Following User Says Thank You to 86TOYO2k17 For This Useful Post:
kev0 (07-06-2019)
Old 07-06-2019, 04:50 PM   #6
kev0
AUTOMATIC TRANNY
 
Join Date: Feb 2018
Drives: 2014 FRS AT
Location: Chicago, IL
Posts: 188
Thanks: 122
Thanked 20 Times in 17 Posts
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by 86TOYO2k17 View Post
Did you pull the brake booster hose cap off your old manifold and reinstall on back of supercharger manifold brake booster port? Are you running the brake booster to the engine without the check valve? Autos run brake booster to the engine with no check valve, and thus the brake booster port on back of manifold needs to be capped.
Yes to all of them. Don't know why my brakes are still firm.. ugh. Brakes work fine though during the drive..it's just...pretty hard to press down.
kev0 is offline   Reply With Quote
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Pressing brakes hard in snow (Terrible Noise) Benschneider06 Issues | Warranty | Recalls / TSB 10 01-20-2016 09:15 PM
Halp! Supercharger extremely loud autograph Forced Induction 15 09-24-2015 04:32 PM
Brakes feel 'stiffer' than usual after pumping 1Cor10:23 Suspension | Chassis | Brakes -- Sponsored by 949 Racing 3 04-14-2014 01:57 PM
How do you feel about stock brakes? SillySaxon Suspension | Chassis | Brakes -- Sponsored by 949 Racing 21 09-16-2013 09:26 AM
why does the BRZ's brake feel firmer after a hard stop? chenshuo Subaru BRZ General Forum 12 05-29-2013 05:32 PM


All times are GMT -4. The time now is 05:13 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Garage vBulletin Plugins by Drive Thru Online, Inc.