follow ft86club on our blog, twitter or facebook.
FT86CLUB
Ft86Club
Speed By Design
Register Garage Members List Calendar Search Today's Posts Mark Forums Read

Go Back   Toyota GR86, 86, FR-S and Subaru BRZ Forum - FT86CLUB > Technical Topics > Engine Swaps

Engine Swaps Discussion of engine swaps.


User Tag List

Reply
 
Thread Tools Search this Thread
Old 10-23-2019, 12:09 PM   #211
Ashikabi
Senior Member
 
Ashikabi's Avatar
 
Join Date: Aug 2014
Drives: 2013 FR-S
Location: Northwest Iowa
Posts: 6,807
Thanks: 444
Thanked 4,220 Times in 2,746 Posts
Mentioned: 57 Post(s)
Tagged: 5 Thread(s)
Quote:
Originally Posted by TunaNoCrust View Post
150 for GM Computer, 150 for harness rework, 150 mail order base tune.
I actually have a computer and harness. It's the canbus module cost and what I'll lose on the Hydra but at this point I guess I don't really care about that if it fixes my problem. I assuming it's tune related, then someone familiar with LS tuning should be able to figure it out pretty quick. It's not like the Hydra uses a different language. It seems it's out of my league though. Maybe I should call some local shops. I know one shop 2 hours away advertises a "complete tuning service" including idle and cranking
Ashikabi is offline   Reply With Quote
Old 10-23-2019, 12:35 PM   #212
TunaNoCrust
Member
 
TunaNoCrust's Avatar
 
Join Date: Apr 2019
Drives: 86, 981S, RX8, 2500HD, GenesisV8
Location: Palmer Motorsports
Posts: 92
Thanks: 71
Thanked 64 Times in 37 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by Ashikabi View Post
I actually have a computer and harness. It's the canbus module cost and what I'll lose on the Hydra but at this point I guess I don't really care about that if it fixes my problem. I assuming it's tune related, then someone familiar with LS tuning should be able to figure it out pretty quick. It's not like the Hydra uses a different language. It seems it's out of my league though. Maybe I should call some local shops. I know one shop 2 hours away advertises a "complete tuning service" including idle and cranking
Canbus functions can probably be done with an Arduino...with the CanBus shield I think total was $70.

The tuning is similar, but requires their own proprietary software.

Borrowing somebody else's tune is a good test to point you in the right direction.
TunaNoCrust is offline   Reply With Quote
Old 10-23-2019, 12:51 PM   #213
Ashikabi
Senior Member
 
Ashikabi's Avatar
 
Join Date: Aug 2014
Drives: 2013 FR-S
Location: Northwest Iowa
Posts: 6,807
Thanks: 444
Thanked 4,220 Times in 2,746 Posts
Mentioned: 57 Post(s)
Tagged: 5 Thread(s)
Quote:
Originally Posted by TunaNoCrust View Post
Canbus functions can probably be done with an Arduino...with the CanBus shield I think total was $70.



The tuning is similar, but requires their own proprietary software.



Borrowing somebody else's tune is a good test to point you in the right direction.
What's the MRS module run at now? I don't want to figure out programming
Ashikabi is offline   Reply With Quote
Old 10-23-2019, 02:56 PM   #214
DustinS
Senior Member
 
DustinS's Avatar
 
Join Date: Apr 2014
Drives: 2013 Ultramarine FR-S
Location: Springfield, MO
Posts: 1,880
Thanks: 2,394
Thanked 1,305 Times in 755 Posts
Mentioned: 29 Post(s)
Tagged: 3 Thread(s)
Quote:
Originally Posted by Ashikabi View Post
What's the MRS module run at now? I don't want to figure out programming
No longer available. The guy that was working on the project is no longer with the company. They have taken everything for it off their website.
__________________
DustinS is offline   Reply With Quote
Old 10-23-2019, 03:01 PM   #215
Ashikabi
Senior Member
 
Ashikabi's Avatar
 
Join Date: Aug 2014
Drives: 2013 FR-S
Location: Northwest Iowa
Posts: 6,807
Thanks: 444
Thanked 4,220 Times in 2,746 Posts
Mentioned: 57 Post(s)
Tagged: 5 Thread(s)
Quote:
Originally Posted by DustinS View Post
No longer available. The guy that was working on the project is no longer with the company. They have taken everything for it off their website.
Explains why I can't find it... So how are people doing this without a standalone?
Ashikabi is offline   Reply With Quote
Old 10-23-2019, 03:52 PM   #216
Sportsguy83
I Love custom Turbo kits
 
Sportsguy83's Avatar
 
Join Date: Mar 2012
Drives: Limited BRZ
Location: Miami
Posts: 10,761
Thanks: 19,998
Thanked 8,324 Times in 4,353 Posts
Mentioned: 440 Post(s)
Tagged: 12 Thread(s)
Garage
Quote:
Originally Posted by Ashikabi View Post
Well guys, I need your help again... My starting problems have not gone away. My flywheel is now missing teeth from the starter kicking out and I've decided to retire the car for the season. I need information on where to go from here though.

I think I'm going to replace the crank sensor as a precaution. It's only about $70 and not hard to replace.

It occurred to me yesterday that maybe my fuel rails become vapor locked (or something???) so the fuel injectors have to cycle through all the air or whatever before I can get fuel. Seems unlikely but it seems everyone has a return system for fueling except me. I essentially reused the stock system on the car side and the stock LS rail on the engine. Do you guys think a return style fuel system will help my hard/no start? How are your systems setup? PS I don't want to use the Radium hanger because I can't spend the money
I run stock returnelss system and don't have those issues. I say try and figure it out before spending that money.
Sportsguy83 is offline   Reply With Quote
Old 10-23-2019, 04:02 PM   #217
Ashikabi
Senior Member
 
Ashikabi's Avatar
 
Join Date: Aug 2014
Drives: 2013 FR-S
Location: Northwest Iowa
Posts: 6,807
Thanks: 444
Thanked 4,220 Times in 2,746 Posts
Mentioned: 57 Post(s)
Tagged: 5 Thread(s)
Quote:
Originally Posted by Sportsguy83 View Post
I run stock returnelss system and don't have those issues. I say try and figure it out before spending that money.
So looking at everyone's opinions here... I'm back where I started, it's either tuning or an electronic problem
Ashikabi is offline   Reply With Quote
Old 10-23-2019, 09:04 PM   #218
toast
Senior Member
 
Join Date: Jul 2014
Drives: 14 BSP Edelbrock BRZ
Location: Lon Gisland
Posts: 780
Thanks: 109
Thanked 423 Times in 242 Posts
Mentioned: 12 Post(s)
Tagged: 0 Thread(s)
I can't see how a tuning issue gives you a random result of 1 of 4 outcomes when you try to start it. That screams intermittent electrical issue to me.
toast is offline   Reply With Quote
Old 10-23-2019, 09:09 PM   #219
Ashikabi
Senior Member
 
Ashikabi's Avatar
 
Join Date: Aug 2014
Drives: 2013 FR-S
Location: Northwest Iowa
Posts: 6,807
Thanks: 444
Thanked 4,220 Times in 2,746 Posts
Mentioned: 57 Post(s)
Tagged: 5 Thread(s)
Quote:
Originally Posted by toast View Post
I can't see how a tuning issue gives you a random result of 1 of 4 outcomes when you try to start it. That screams intermittent electrical issue to me.
That's what I thought but I've spent many hours digging in my wiring and haven't found shit
Ashikabi is offline   Reply With Quote
Old 12-01-2019, 01:51 PM   #220
Ashikabi
Senior Member
 
Ashikabi's Avatar
 
Join Date: Aug 2014
Drives: 2013 FR-S
Location: Northwest Iowa
Posts: 6,807
Thanks: 444
Thanked 4,220 Times in 2,746 Posts
Mentioned: 57 Post(s)
Tagged: 5 Thread(s)
Confirmed you can drop the transmission with the motor "in" the car, if you drop the subframe.

Flywheel is coming out for ring gear service since the starter broke off half the teeth on it. Hydra EMS is going in for service too since the MAP reads higher than it should. Also on the list is wiring the cam sensor for more accurate crank position information. I'm replacing the crank sensor too just in case
Ashikabi is offline   Reply With Quote
Old 06-18-2020, 09:42 AM   #221
Ashikabi
Senior Member
 
Ashikabi's Avatar
 
Join Date: Aug 2014
Drives: 2013 FR-S
Location: Northwest Iowa
Posts: 6,807
Thanks: 444
Thanked 4,220 Times in 2,746 Posts
Mentioned: 57 Post(s)
Tagged: 5 Thread(s)
Been a while but I'll give a short update.

Had a problem with the shifter bit going into gear from a stop. Also getting locked out of gears at high RPM. Appears to have been caused by a misadjusted clutch pedal. So if you're having shifting problems check that first!

I've almost got all the bugs worked out. Synced up the cam sensor so now it starts every time I turn the key! So excited to have that fixed. However, according to my timing light, my timing is right at idle but gets way way off at any other rpm. This may just be because I'm not familiar with how the timing light should look with the Wasted Spark firing system (cylinders fire in opposing pairs). So cylinder 1 fires once for ignition and again when #5 or whichever ignites. The timing light will then flash again at who knows what angle. We will be rewiring the ignition for sequential firing soon. This is the last hurdle to pass before this swap is "done". I am leaning towards adding a turbo in the future but who knows when that will be.

Air conditioning does work, I'll be posting about that soon

Sent from my ONEPLUS A5010 using Tapatalk
Ashikabi is offline   Reply With Quote
Old 06-18-2020, 10:14 AM   #222
vijay.dy06
Member
 
Join Date: Aug 2017
Drives: Red BRZ
Location: North Carolina
Posts: 66
Thanks: 1
Thanked 16 Times in 10 Posts
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by Ashikabi View Post
Confirmed you can drop the transmission with the motor "in" the car, if you drop the subframe.

Flywheel is coming out for ring gear service since the starter broke off half the teeth on it. Hydra EMS is going in for service too since the MAP reads higher than it should. Also on the list is wiring the cam sensor for more accurate crank position information. I'm replacing the crank sensor too just in case
When you dropped the subframe, did you have a cherry picker supporting the engine up? I need to change my clutch out.

Sent from my SM-G950U using Tapatalk
vijay.dy06 is offline   Reply With Quote
Old 06-18-2020, 10:21 AM   #223
Ashikabi
Senior Member
 
Ashikabi's Avatar
 
Join Date: Aug 2014
Drives: 2013 FR-S
Location: Northwest Iowa
Posts: 6,807
Thanks: 444
Thanked 4,220 Times in 2,746 Posts
Mentioned: 57 Post(s)
Tagged: 5 Thread(s)
Quote:
Originally Posted by vijay.dy06 View Post
When you dropped the subframe, did you have a cherry picker supporting the engine up? I need to change my clutch out.

Sent from my SM-G950U using Tapatalk
I just used a jack underneath. Had to take off my intake manifold and disconnect coolant lines. Kinda makes you wish you'd replaced your transmission tunnel when you had the chance but it is better than pulling the whole thing out

Sent from my ONEPLUS A5010 using Tapatalk
Ashikabi is offline   Reply With Quote
Old 07-27-2020, 09:49 PM   #224
Ashikabi
Senior Member
 
Ashikabi's Avatar
 
Join Date: Aug 2014
Drives: 2013 FR-S
Location: Northwest Iowa
Posts: 6,807
Thanks: 444
Thanked 4,220 Times in 2,746 Posts
Mentioned: 57 Post(s)
Tagged: 5 Thread(s)
My pilot bearing failed so I'm replacing it and my slave. Got a heavy duty Ram slave unit.

FYI. If you are using a T56 you need the smaller needle bearing style pilot bearing. If you are using a TR6060 you need the much larger sealed ball bearing unit. BEWARE! There are 2 sizes of the larger pilot. One for aftermarket cranks and one for stock cranks. Of course I got the wrong one from Summit. That's how I found out about the multiple sizes. Also, there is an extended needle bearing unit if you feel you need that

Sent from my ONEPLUS A5010 using Tapatalk
Ashikabi is offline   Reply With Quote
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 08:59 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
User Alert System provided by Advanced User Tagging v3.3.0 (Lite) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Garage vBulletin Plugins by Drive Thru Online, Inc.