follow ft86club on our blog, twitter or facebook.
FT86CLUB
Ft86Club
Delicious Tuning
Register Garage Members List Calendar Search Today's Posts Mark Forums Read

Go Back   Scion FR-S Forum | Subaru BRZ Forum | Toyota 86 GT 86 Forum | AS1 Forum - FT86CLUB > Technical Topics > Mechanical Maintenance (Oil, Fluids, Break-In, Servicing)

Mechanical Maintenance (Oil, Fluids, Break-In, Servicing) Everything related to the mechanical maintenance of the FR-S and BRZ


User Tag List

Reply
 
Thread Tools Search this Thread
Old 05-17-2019, 03:14 PM   #1
msaikhan
Senior Member
 
Join Date: Jun 2018
Drives: frs
Location: arlingtong va
Posts: 106
Thanks: 23
Thanked 31 Times in 20 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Cam sensor leaking oil?

2013 frs, replaced short block

I saw some oil dripping from the bottom of engine on passenger side, while replacing headers. Oil got on the grounding wire on the bottom of the engine.

I'm pretty sure it's coming from the cam sensor, top passenger side. Got O rings from subaru and planning on changing the o ring.

Anyone else had this problem?

I'm not taking it the car back to the dealer, usually comes back with another problem.
msaikhan is offline   Reply With Quote
Old 05-18-2019, 08:00 AM   #2
Vital
Senior Member
 
Join Date: Jun 2016
Drives: 2015 BRZ
Location: Texas
Posts: 417
Thanks: 109
Thanked 184 Times in 133 Posts
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by msaikhan View Post
2013 frs, replaced short block

I saw some oil dripping from the bottom of engine on passenger side, while replacing headers. Oil got on the grounding wire on the bottom of the engine.

I'm pretty sure it's coming from the cam sensor, top passenger side. Got O rings from subaru and planning on changing the o ring.

Anyone else had this problem?

I'm not taking it the car back to the dealer, usually comes back with another problem.
Yes its a common issue on earlier models. http://www.ft86club.com/forums/attac...1&d=1413834741
Vital is offline   Reply With Quote
The Following User Says Thank You to Vital For This Useful Post:
msaikhan (05-18-2019)
Old 05-18-2019, 10:31 AM   #3
msaikhan
Senior Member
 
Join Date: Jun 2018
Drives: frs
Location: arlingtong va
Posts: 106
Thanks: 23
Thanked 31 Times in 20 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by Vital View Post
Yes its a common issue on earlier models. http://www.ft86club.com/forums/attac...1&d=1413834741
i seen this before but none of these are about the cam sensor oil leak.
msaikhan is offline   Reply With Quote
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
P0140 Oxygen Sensor Circuit No Activity Detected (Bank 1 Sensor 2) Help Johnders2586 Issues | Warranty | Recalls / TSB 2 02-01-2018 04:14 PM
Leaking oil next to o2 sensor! Updated feldy Issues | Warranty | Recalls / TSB 5 05-11-2015 10:40 PM
Greddy informeter, boost sensor, boost sensor harness, info touch sensor apaptor Supra2k Audio/Visual, Electronics, Infotainment, NAV 1 02-26-2014 09:11 PM
Stock FA20 Crankshaft Angle Sensor - Anyone know what type of sensor and output? Acree Engine, Exhaust, Transmission 2 08-26-2013 06:39 PM


All times are GMT -4. The time now is 01:37 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Garage vBulletin Plugins by Drive Thru Online, Inc.