follow ft86club on our blog, twitter or facebook.
FT86CLUB
Ft86Club
Delicious Tuning
Register Garage Members List Calendar Search Today's Posts Mark Forums Read

Go Back   Toyota GR86, 86, FR-S and Subaru BRZ Forum & Owners Community - FT86CLUB > 1st Gens: Scion FR-S / Toyota 86 / Subaru BRZ > Scion FR-S / Toyota 86 GT86 General Forum

Scion FR-S / Toyota 86 GT86 General Forum The place to start for the Scion FR-S / Toyota 86 | GT86


User Tag List
torqdork

Reply
 
Thread Tools Search this Thread
Old 05-17-2019, 09:26 PM   #2381
Decep
Senior Member
 
Join Date: May 2017
Drives: 2013 FR-S Series 10
Location: CA
Posts: 887
Thanks: 93
Thanked 382 Times in 258 Posts
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
I wouldn't mind ripping mine out and replacing it with the newer leather (vinyl?) dash.
Decep is offline   Reply With Quote
The Following User Says Thank You to Decep For This Useful Post:
roosahorn (05-17-2019)
Old 05-17-2019, 09:48 PM   #2382
roosahorn
Member
 
Join Date: Apr 2014
Drives: 2013 FRS 10 Series
Location: Los Angeles
Posts: 26
Thanks: 11
Thanked 8 Times in 8 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by Decep View Post
I wouldn't mind ripping mine out and replacing it with the newer leather (vinyl?) dash.
Sweidit'd mine. Looks a lot better.

Sent from my SM-N950U using Tapatalk
roosahorn is offline   Reply With Quote
Old 05-18-2019, 01:29 AM   #2383
Trist0n
Member
 
Trist0n's Avatar
 
Join Date: May 2019
Drives: FRS 10 Series
Location: Florida
Posts: 29
Thanks: 3
Thanked 16 Times in 8 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by MJones_RB View Post
FWIR, once they break they're broke. All you can do is replace them, if possible. Scion is gone and with it went all these cool things. I do believe some Priuses (Prii?) have EL badges but I'm not sure. I asked a Toyota parts tech if the parts could be replaced but he couldn't find a part # for them.


Damn shame. If itís already a lost cause I might see if I can wire it into something else, or maybe just rig up my own solution to replace the lighting? Iíll have to take a look this weekend


Sent from my iPhone using Tapatalk
Trist0n is offline   Reply With Quote
The Following 2 Users Say Thank You to Trist0n For This Useful Post:
FR-Sky (05-18-2019), MJones_RB (05-21-2019)
Old 05-18-2019, 09:47 AM   #2384
FR-Sky
Senior Member
 
FR-Sky's Avatar
 
Join Date: Dec 2015
Drives: 2013 FR-S 10 series [755]
Location: Bay Area, CA
Posts: 1,189
Thanks: 385
Thanked 390 Times in 264 Posts
Mentioned: 7 Post(s)
Tagged: 2 Thread(s)
Quote:
Originally Posted by Trist0n View Post
Damn shame. If itís already a lost cause I might see if I can wire it into something else, or maybe just rig up my own solution to replace the lighting? Iíll have to take a look this weekend


Sent from my iPhone using Tapatalk
I once heard that if you prove the ownership of the car such as VIN and Registration, they can help you order the parts.
__________________
IG: @rearwheelclub
FR-Sky is offline   Reply With Quote
The Following User Says Thank You to FR-Sky For This Useful Post:
SC10N (03-24-2020)
Old 05-19-2019, 02:43 PM   #2385
Tien0227
Member
 
Tien0227's Avatar
 
Join Date: May 2013
Drives: FRS 10 Series MT
Location: Ga
Posts: 97
Thanks: 59
Thanked 48 Times in 36 Posts
Mentioned: 2 Post(s)
Tagged: 2 Thread(s)
Garage
Still loving mine at 55k. Though my EL stopped working too.


Sent from my SM-G955U using Tapatalk
Tien0227 is offline   Reply With Quote
The Following 2 Users Say Thank You to Tien0227 For This Useful Post:
MJones_RB (05-20-2019), SC10N (03-24-2020)
Old 05-19-2019, 03:00 PM   #2386
Trist0n
Member
 
Trist0n's Avatar
 
Join Date: May 2019
Drives: FRS 10 Series
Location: Florida
Posts: 29
Thanks: 3
Thanked 16 Times in 8 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
FR-S 10 Series Registry

Quote:
Originally Posted by Tien0227 View Post
Still loving mine at 55k. Though my EL stopped working too.


Sent from my SM-G955U using Tapatalk

I took a look at mine, looks like the controller might be done and the EL strip is burned out. I canít find any info on replacing it, and something tells me that the OEM parts would be hella expensive. Upon pulling my dash apart it looks to be a plain EL strip behind the panel, I picked one up thatís the same size off eBay. I think Iíll make a vinyl overlay to have it say series 10 + my number or something and wire it into my cabin accent lighting. If it works out I think itíll look cool

Edit: also I love the purple!
Trist0n is offline   Reply With Quote
The Following 2 Users Say Thank You to Trist0n For This Useful Post:
MJones_RB (05-20-2019), SC10N (03-24-2020)
Old 05-20-2019, 02:05 PM   #2387
MJones_RB
Senior Member
 
MJones_RB's Avatar
 
Join Date: Sep 2013
Drives: Scion FR-S Series 10 #2462
Location: Redondo Beach, CA
Posts: 829
Thanks: 2,768
Thanked 516 Times in 295 Posts
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Garage
Quote:
Originally Posted by Trist0n View Post
I took a look at mine, looks like the controller might be done and the EL strip is burned out. I canít find any info on replacing it, and something tells me that the OEM parts would be hella expensive. Upon pulling my dash apart it looks to be a plain EL strip behind the panel, I picked one up thatís the same size off eBay. I think Iíll make a vinyl overlay to have it say series 10 + my number or something and wire it into my cabin accent lighting. If it works out I think itíll look cool

Edit: also I love the purple!
Come to think of it, I can't remember the last time I saw my dash EL light up...
MJones_RB is offline   Reply With Quote
Old 05-20-2019, 02:11 PM   #2388
Trist0n
Member
 
Trist0n's Avatar
 
Join Date: May 2019
Drives: FRS 10 Series
Location: Florida
Posts: 29
Thanks: 3
Thanked 16 Times in 8 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by MJones_RB View Post
Come to think of it, I can't remember the last time I saw my dash EL light up...


It seems to be a pretty common thing for it to burn out
Trist0n is offline   Reply With Quote
The Following User Says Thank You to Trist0n For This Useful Post:
MJones_RB (05-20-2019)
Old 05-21-2019, 12:01 PM   #2389
Cheeky
Member
 
Join Date: Mar 2018
Drives: 10 Series FRS
Location: Mississauga
Posts: 80
Thanks: 140
Thanked 52 Times in 27 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Over 100k on mine... daily it (2nd owner).

My back Emblem stopped working... at the beginning of ownership I was slightly embarassed that it would light up so bright at night.

Now I miss it...
Cheeky is offline   Reply With Quote
The Following 4 Users Say Thank You to Cheeky For This Useful Post:
FR-Sky (05-22-2019), MJones_RB (05-21-2019), SC10N (03-24-2020), Tcoat (05-21-2019)
Old 05-22-2019, 02:23 PM   #2390
Tien0227
Member
 
Tien0227's Avatar
 
Join Date: May 2013
Drives: FRS 10 Series MT
Location: Ga
Posts: 97
Thanks: 59
Thanked 48 Times in 36 Posts
Mentioned: 2 Post(s)
Tagged: 2 Thread(s)
Garage
Quote:
Originally Posted by Trist0n View Post
I took a look at mine, looks like the controller might be done and the EL strip is burned out. I canít find any info on replacing it, and something tells me that the OEM parts would be hella expensive. Upon pulling my dash apart it looks to be a plain EL strip behind the panel, I picked one up thatís the same size off eBay. I think Iíll make a vinyl overlay to have it say series 10 + my number or something and wire it into my cabin accent lighting. If it works out I think itíll look cool

Edit: also I love the purple!
Good luck! And thank you!


Sent from my SM-G955U using Tapatalk
Tien0227 is offline   Reply With Quote
Old 05-22-2019, 02:52 PM   #2391
FR-Sky
Senior Member
 
FR-Sky's Avatar
 
Join Date: Dec 2015
Drives: 2013 FR-S 10 series [755]
Location: Bay Area, CA
Posts: 1,189
Thanks: 385
Thanked 390 Times in 264 Posts
Mentioned: 7 Post(s)
Tagged: 2 Thread(s)
Quote:
Originally Posted by Cheeky View Post
Over 100k on mine... daily it (2nd owner).

My back Emblem stopped working... at the beginning of ownership I was slightly embarassed that it would light up so bright at night.

Now I miss it...
Mine still works!!!! @70k
__________________
IG: @rearwheelclub
FR-Sky is offline   Reply With Quote
The Following User Says Thank You to FR-Sky For This Useful Post:
Cheeky (05-22-2019)
Old 05-22-2019, 09:04 PM   #2392
Decep
Senior Member
 
Join Date: May 2017
Drives: 2013 FR-S Series 10
Location: CA
Posts: 887
Thanks: 93
Thanked 382 Times in 258 Posts
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Same, all emblems working @ 50k.

For you guys whose are not working, did you do any electrical mods like stereo, headlight etc? Wonder if its a fuse or wiring thing.
Decep is offline   Reply With Quote
Old 05-22-2019, 09:40 PM   #2393
Trist0n
Member
 
Trist0n's Avatar
 
Join Date: May 2019
Drives: FRS 10 Series
Location: Florida
Posts: 29
Thanks: 3
Thanked 16 Times in 8 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by Decep View Post
Same, all emblems working @ 50k.

For you guys whose are not working, did you do any electrical mods like stereo, headlight etc? Wonder if its a fuse or wiring thing.


My emblems still work after stereo and headlight mods, itís just the EL thatís gone. From what I can tell theyíre on a pretty separate system from the rest of the wiring, the emblems and the EL each have their own controllers.
Trist0n is offline   Reply With Quote
Old 05-24-2019, 10:01 PM   #2394
Trist0n
Member
 
Trist0n's Avatar
 
Join Date: May 2019
Drives: FRS 10 Series
Location: Florida
Posts: 29
Thanks: 3
Thanked 16 Times in 8 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)


Ladies and gents I fixed it! Ignore my plastic wrap on the ground. Like I suspected the burned out EL panel had a film over it with the scion logo and lettering, so I peeled that off and applied it to my eBay EL strip. I wanted to leave the stock EL wiring alone in case I run into OEM parts someday so I ran an inverter off a tap from the drivers side fusebox, and routed a connector up to the hole behind the dashboard. That way if it ever burns out again it should be a super easy fix, simple disconnect and swap. It is now on all the time, but personally I like it that way, since itís very unobtrusive, matches my accent lighting, and you canít see it at all in the daytime. Itís also a ~20$ repair instead of a 400$+ repair if you can even find the parts. If anyone wants a more detailed list of what I did feel free to reach out.
Trist0n is offline   Reply With Quote
The Following 4 Users Say Thank You to Trist0n For This Useful Post:
czechm8 (05-24-2019), jflogerzi (05-24-2019), SC10N (05-24-2019), Tien0227 (07-03-2019)
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
**Tennessee Registry** Xryn Southeast 138 01-04-2022 04:52 PM
Mid-Atlantic Owners Registry. IloveBaldEagles Mid-Atlantic 364 10-12-2021 01:44 AM
86 Owners of New England - Registry MannyO New England 248 03-12-2020 09:00 PM
Issue updating Registry. IloveBaldEagles Site Announcements / Questions / Issues 1 03-18-2013 08:19 PM
First 86 Registry: 2013 Scion FR-S Flipside909 Scion FR-S / Toyota 86 GT86 General Forum 44 05-18-2012 06:54 PM


All times are GMT -4. The time now is 12:31 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
User Alert System provided by Advanced User Tagging v3.3.0 (Lite) - vBulletin Mods & Addons Copyright © 2022 DragonByte Technologies Ltd.

Garage vBulletin Plugins by Drive Thru Online, Inc.