follow ft86club on our blog, twitter or facebook.
FT86CLUB
Ft86Club
Speed By Design
Register Garage Members List Calendar Search Today's Posts Mark Forums Read

Go Back   Toyota GR86, 86, FR-S and Subaru BRZ Forum & Owners Community - FT86CLUB > Technical Topics > Issues | Warranty | Recalls / TSB

Issues | Warranty | Recalls / TSB Problems, issues, recalls, TSBs


User Tag List

Reply
 
Thread Tools Search this Thread
Old 02-12-2023, 03:07 PM   #1
Velocsity
Junior Member
 
Join Date: Feb 2023
Drives: 2015 Scion FRS
Location: California
Posts: 4
Thanks: 0
Thanked 2 Times in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
2015 FRS Windows not working (No flashing/blinking window switches)

I'm new to this but I had to make this post because I can't find anything online.

My windows don't roll down or up. I've tried the resetting method and it was working at first every time this occurred but last night it seemed to finally give up completely. At first the lights would blink/flash but last night turned off completely so i cant do the reset method anymore. In the beginning it was only the driver side door switches that didn't roll down either window and my passenger switch worked for the passenger window but this morning it also stopped working. When I open and close the driver door the window doesn't do the auto slightly open thing it normally does but my passenger door still does. Also my unlock/lock door button on my driver side stopped working but it works on my passenger door. I check the fuses and they both looked fine. I ordered a driver side window switch but that's when I noticed the passenger side wasn't working either. I don't know if they both don't work because of the driver side switch. The only things that work are the side mirrors knob and the passenger lock and unlock button. I was wondering if there's some wiring that has to do with this under my dash by my feet and if so, where do I look?
Velocsity is offline   Reply With Quote
Old 02-12-2023, 07:59 PM   #2
humfrz
Senior Member
 
Join Date: May 2013
Drives: 2013 FR-S, white, MT
Location: Puyallup, WA
Posts: 29,930
Thanks: 28,891
Thanked 31,935 Times in 16,471 Posts
Mentioned: 709 Post(s)
Tagged: 2 Thread(s)
Welcome to our gang, there Velocsity -

Have you checked both fuses?

(#10 and # 14) (at least on my 2013)

Do you have a multimeter to go hunting with?

Come back.

I'll ring up ol @soundman98 for you, he is pretty good with electrical stuff.
humfrz is offline   Reply With Quote
Old 02-13-2023, 12:48 AM   #3
Velocsity
Junior Member
 
Join Date: Feb 2023
Drives: 2015 Scion FRS
Location: California
Posts: 4
Thanks: 0
Thanked 2 Times in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by humfrz View Post
Welcome to our gang, there Velocsity -

Have you checked both fuses?

(#10 and # 14) (at least on my 2013)

Do you have a multimeter to go hunting with?

Come back.

I'll ring up ol @soundman98 for you, he is pretty good with electrical stuff.
Yeah I have one. I also checked both. They looked fine but I still replaced them with new ones. The main thing that is odd to me is that both window switches don't work. Like they both decided to go out around the same time.
Velocsity is offline   Reply With Quote
Old 02-13-2023, 08:20 AM   #4
Tcoat
Senior Member
 
Tcoat's Avatar
 
Join Date: Jul 2014
Drives: 2020 Hakone
Location: London, Ont
Posts: 69,845
Thanks: 61,656
Thanked 108,286 Times in 46,456 Posts
Mentioned: 2495 Post(s)
Tagged: 50 Thread(s)
Quote:
Originally Posted by Velocsity View Post
Yeah I have one. I also checked both. They looked fine but I still replaced them with new ones. The main thing that is odd to me is that both window switches don't work. Like they both decided to go out around the same time.
I know this is basic and not trying to insult intelligence but have you checked that the window lock button wasn't pushed?
__________________
Racecar spelled backwards is Racecar, because Racecar.
Tcoat is offline   Reply With Quote
The Following 2 Users Say Thank You to Tcoat For This Useful Post:
Ultramaroon (02-13-2023), x808drifter (02-13-2023)
Old 02-13-2023, 12:16 PM   #5
Velocsity
Junior Member
 
Join Date: Feb 2023
Drives: 2015 Scion FRS
Location: California
Posts: 4
Thanks: 0
Thanked 2 Times in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by Tcoat View Post
I know this is basic and not trying to insult intelligence but have you checked that the window lock button wasn't pushed?
Yeah it's not pushed. I've pushed it in and out just to see if it would miraculously fix.
Velocsity is offline   Reply With Quote
The Following 2 Users Say Thank You to Velocsity For This Useful Post:
Tcoat (02-13-2023), x808drifter (02-14-2023)
Old 02-13-2023, 12:18 PM   #6
Tcoat
Senior Member
 
Tcoat's Avatar
 
Join Date: Jul 2014
Drives: 2020 Hakone
Location: London, Ont
Posts: 69,845
Thanks: 61,656
Thanked 108,286 Times in 46,456 Posts
Mentioned: 2495 Post(s)
Tagged: 50 Thread(s)
Quote:
Originally Posted by Velocsity View Post
Yeah it's not pushed. I've pushed it in and out just to see if it would miraculously fix.
Was worth asking. We have seen that issue many many times!
Does sound like a connection issue but I believe all the connectors are inside the door.
__________________
Racecar spelled backwards is Racecar, because Racecar.
Tcoat is offline   Reply With Quote
Old 02-13-2023, 07:57 PM   #7
Velocsity
Junior Member
 
Join Date: Feb 2023
Drives: 2015 Scion FRS
Location: California
Posts: 4
Thanks: 0
Thanked 2 Times in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by Tcoat View Post
Was worth asking. We have seen that issue many many times!
Does sound like a connection issue but I believe all the connectors are inside the door.
I'm just waiting on the window switch to arrive to see if it's that. Hopefully nothing more.
Velocsity is offline   Reply With Quote
Old 02-13-2023, 08:23 PM   #8
soundman98
ProCrastinationConsultant
 
soundman98's Avatar
 
Join Date: Sep 2013
Drives: '14 Ranger, '18 Tacoma 4Dr LB
Location: chicago-ish
Posts: 11,330
Thanks: 35,240
Thanked 13,673 Times in 6,781 Posts
Mentioned: 98 Post(s)
Tagged: 0 Thread(s)
how old is your battery?

otherwise, it really sounds like a connection issue within the door. first to check is the connector behind that panel is slightly loose(unplug it and plug it back in to re-seat it). there's also a connector just inside the car in each kick panel for the entire door wiring harness that could've also worked loose.

otherwise, a replacement window/lock switch assembly is the next best thing to replace. there's nothing serviceable about them.
__________________
"The time you enjoy wasting is not wasted time"
soundman98 is offline   Reply With Quote
 
Reply

Tags
door, lock, unlock, windows

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Frs no crank no start, radio, clock, and window switches not working Sumtingwong Issues | Warranty | Recalls / TSB 11 07-06-2020 01:33 AM
Part # for MY17 window switches? Suparu Cosmetic Modification (Interior/Exterior/Lighting) 5 02-01-2020 08:02 PM
BRZ jammed window issue/blinking auto light? Superhatch Issues | Warranty | Recalls / TSB 28 02-15-2015 05:45 AM
Window switches not working right after battery swap jonbonazza Issues | Warranty | Recalls / TSB 9 01-10-2014 02:50 PM


All times are GMT -4. The time now is 07:05 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
User Alert System provided by Advanced User Tagging v3.3.0 (Lite) - vBulletin Mods & Addons Copyright © 2024 DragonByte Technologies Ltd.

Garage vBulletin Plugins by Drive Thru Online, Inc.