follow ft86club on our blog, twitter or facebook.
FT86CLUB
Ft86Club
Speed By Design
Register Garage Members List Calendar Search Today's Posts Mark Forums Read

Go Back   Scion FR-S Forum | Subaru BRZ Forum | Toyota 86 GT 86 Forum | AS1 Forum - FT86CLUB > Subaru BRZ > Subaru BRZ General Forum

Subaru BRZ General Forum All discussions about the Subaru BRZ coupe


User Tag List

Reply
 
Thread Tools Search this Thread
Old 01-13-2019, 07:20 PM   #1
henry.haden
Junior Member
 
Join Date: Jan 2019
Drives: 2013 Subaru BRZ
Location: Atlanta
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Loud Whirring Sound

When I press the starter button, I start hearing this sound before the engine even turns on. It keeps going while Iím driving and only stops a minute after turning the engine off. I have a Cosworth supercharger installed but it might not be that. Any ideas?


Sent from my iPhone using Tapatalk
henry.haden is offline   Reply With Quote
Old 01-13-2019, 08:30 PM   #2
Brink
Senior Member
 
Join Date: Apr 2017
Drives: 2017 BRZ
Location: CA
Posts: 653
Thanks: 192
Thanked 377 Times in 232 Posts
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
As I recall from some previous posts it might be the HU fan. Don't know anything about it myself, just seen some discussion on here about a similar sound.
Brink is offline   Reply With Quote
Old 01-13-2019, 08:39 PM   #3
henry.haden
Junior Member
 
Join Date: Jan 2019
Drives: 2013 Subaru BRZ
Location: Atlanta
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by Brink View Post
As I recall from some previous posts it might be the HU fan. Don't know anything about it myself, just seen some discussion on here about a similar sound.


That sounds like it. Thanks!


Sent from my iPhone using Tapatalk
henry.haden is offline   Reply With Quote
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Whirring sound on idle jerryzilla Issues | Warranty | Recalls / TSB 4 03-24-2018 01:49 AM
Pop, loud whirring no power to the wheels mr. slim Issues | Warranty | Recalls / TSB 22 05-15-2015 02:11 PM
Loud Ripping Sound HachiRo Engine, Exhaust, Transmission 1 04-21-2015 08:55 PM
More sounds; metal whirring sound braking to stop in neutral l0aded Issues | Warranty | Recalls / TSB 2 07-13-2013 02:05 AM
SOUND LEVEL TO LOW!! Not loud enough Hbomb Electronics | Audio | NAV | Infotainment 24 12-21-2012 10:02 AM


All times are GMT -4. The time now is 04:57 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Garage vBulletin Plugins by Drive Thru Online, Inc.