follow ft86club on our blog, twitter or facebook.
FT86CLUB
Ft86Club
Speed By Design
Register Garage Members List Calendar Search Today's Posts Mark Forums Read

Go Back   Toyota GR86, 86, FR-S and Subaru BRZ Forum - FT86CLUB > Technical Topics > Software Tuning

Software Tuning Discuss all software tuning topics.


User Tag List

Reply
 
Thread Tools Search this Thread
Old 03-21-2020, 07:24 PM   #1
powerwdp
Member
 
Join Date: Oct 2018
Drives: 2018 Toyota 86
Location: NJ
Posts: 18
Thanks: 1
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
OFT Unstable revs when shifted to R/D from Parking

Hi I got a 2018 toyota 86 auto recently added JDL catted UEL and OFT tune (Stg-2-v4.03-ZA1JN10D.bin). But after that I found every time after cold start, if I don't let the car fully warmed up, the rev will rise to 2000+ immediately after switching to R/D and then be quite unstable when I releasing the brake.

It make some trouble when I want to move preciously in the garage, just want to know is there any solution for that? I attached a video and the tune file I've used. You can see from the video that I never touch the throttle but the rev is keeping bouncing...

[ame]https://www.youtube.com/watch?v=IlqecsbqOEw[/ame]
Attached Files
File Type: zip Stg-2-v4.03-ZA1JN10D.zip (550.6 KB, 10 views)
powerwdp is offline   Reply With Quote
Old 03-21-2020, 08:32 PM   #2
kev0
AUTOMATIC TRANNY
 
Join Date: Feb 2018
Drives: 2014 FRS AT
Location: Chicago, IL
Posts: 392
Thanks: 181
Thanked 71 Times in 54 Posts
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
How many miles since the tune? If less than 200, check back in after you reach those 200 miles so the fuel trims are fully learned. Post a log if you can. A vacuum leak in the header can cause that.
kev0 is offline   Reply With Quote
Old 03-22-2020, 06:48 AM   #3
steve99
Senior Member
 
steve99's Avatar
 
Join Date: Dec 2013
Drives: FT86
Location: Australia
Posts: 7,658
Thanks: 982
Thanked 4,753 Times in 2,846 Posts
Mentioned: 529 Post(s)
Tagged: 2 Thread(s)
Maf correction after start values are incorrect in both in nrutral and in gear tables.


Ive fixed this for a few people
steve99 is offline   Reply With Quote
Old 03-22-2020, 10:47 AM   #4
powerwdp
Member
 
Join Date: Oct 2018
Drives: 2018 Toyota 86
Location: NJ
Posts: 18
Thanks: 1
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by kev0 View Post
How many miles since the tune? If less than 200, check back in after you reach those 200 miles so the fuel trims are fully learned. Post a log if you can. A vacuum leak in the header can cause that.
it is pretty new with new gaskets, should be under 50 miles, I'll check back later.
powerwdp is offline   Reply With Quote
Old 03-22-2020, 10:48 AM   #5
powerwdp
Member
 
Join Date: Oct 2018
Drives: 2018 Toyota 86
Location: NJ
Posts: 18
Thanks: 1
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by steve99 View Post
Maf correction after start values are incorrect in both in nrutral and in gear tables.


Ive fixed this for a few people
I did some research and found below part may be the one you mentioned.

Code:
		<table name="MAF Correction After Start (Neutral)" storageaddress="11C868">
		  <table type="X Axis" storageaddress="11C81C" />
		  <table type="Y Axis" storageaddress="11C848" />
		</table>
		<table name="MAF Correction After Start (In Gear)" storageaddress="11C964">
			<table type="X Axis" storageaddress="11C918" />
			<table type="Y Axis" storageaddress="11C944" />
		</table>
Can I rewrite the address using the stock value to fix that? Not sure if that will works properly with aftermarket parts...

Thanks!

Last edited by powerwdp; 03-22-2020 at 10:26 PM.
powerwdp is offline   Reply With Quote
Old 03-23-2020, 01:53 AM   #6
steve99
Senior Member
 
steve99's Avatar
 
Join Date: Dec 2013
Drives: FT86
Location: Australia
Posts: 7,658
Thanks: 982
Thanked 4,753 Times in 2,846 Posts
Mentioned: 529 Post(s)
Tagged: 2 Thread(s)
Quote:
Originally Posted by powerwdp View Post
I did some research and found below part may be the one you mentioned.

Code:
        <table name="MAF Correction After Start (Neutral)" storageaddress="11C868">
          <table type="X Axis" storageaddress="11C81C" />
          <table type="Y Axis" storageaddress="11C848" />
        </table>
        <table name="MAF Correction After Start (In Gear)" storageaddress="11C964">
            <table type="X Axis" storageaddress="11C918" />
            <table type="Y Axis" storageaddress="11C944" />
        </table>
Can I rewrite the address using the stock value to fix that? Not sure if that will works properly with aftermarket parts...

Thanks!

The def is correct just the values in table are in correct . You just need to change the valies in the tables in romraider.





Use the values in the maf after start tavles at bottom of the picture below ie the tavles with max value 20, copy in the whole table to your tune, make both in gear and in neutral same





steve99 is offline   Reply With Quote
Old 03-23-2020, 04:26 PM   #7
powerwdp
Member
 
Join Date: Oct 2018
Drives: 2018 Toyota 86
Location: NJ
Posts: 18
Thanks: 1
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by steve99 View Post
The def is correct just the values in table are in correct . You just need to change the valies in the tables in romraider.





Use the values in the maf after start tavles at bottom of the picture below ie the tavles with max value 20, copy in the whole table to your tune, make both in gear and in neutral same





Thanks for the information!

I've downloaded romraider and check my value, it looks a little bit different. The value is higher for idle mode 7/8 and has a low-high-low trend for in gear table.

should I make the in gear table exactly same as neutral table or keep its trend but lower the number?

powerwdp is offline   Reply With Quote
Old 03-23-2020, 06:18 PM   #8
steve99
Senior Member
 
steve99's Avatar
 
Join Date: Dec 2013
Drives: FT86
Location: Australia
Posts: 7,658
Thanks: 982
Thanked 4,753 Times in 2,846 Posts
Mentioned: 529 Post(s)
Tagged: 2 Thread(s)
Just make fhe in gear an neutral tables same, that way when you shift from neutral to a gear the rpm wont change


From memory ghe original tavles had higher values at bottom rows which made rpm rise more as car warmed up
steve99 is offline   Reply With Quote
The Following User Says Thank You to steve99 For This Useful Post:
Lantanafrs2 (03-24-2020)
Old 03-23-2020, 10:20 PM   #9
powerwdp
Member
 
Join Date: Oct 2018
Drives: 2018 Toyota 86
Location: NJ
Posts: 18
Thanks: 1
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by steve99 View Post
Just make fhe in gear an neutral tables same, that way when you shift from neutral to a gear the rpm wont change


From memory ghe original tavles had higher values at bottom rows which made rpm rise more as car warmed up
Just want to confirm that I haven't done something wrong...

powerwdp is offline   Reply With Quote
Old 03-24-2020, 03:42 AM   #10
steve99
Senior Member
 
steve99's Avatar
 
Join Date: Dec 2013
Drives: FT86
Location: Australia
Posts: 7,658
Thanks: 982
Thanked 4,753 Times in 2,846 Posts
Mentioned: 529 Post(s)
Tagged: 2 Thread(s)
Swap rows 1,2 with 7,8 in both tables


Tats whats causing issue
steve99 is offline   Reply With Quote
The Following User Says Thank You to steve99 For This Useful Post:
Decep (03-25-2020)
Old 03-24-2020, 02:22 PM   #11
powerwdp
Member
 
Join Date: Oct 2018
Drives: 2018 Toyota 86
Location: NJ
Posts: 18
Thanks: 1
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by steve99 View Post
Swap rows 1,2 with 7,8 in both tables


Tats whats causing issue
That solved the problem, I really appreciate it!

Can you describe a little about difference between row 1/2 with 7/8? Not sure why they switch those row for later map.
powerwdp is offline   Reply With Quote
The Following User Says Thank You to powerwdp For This Useful Post:
Boomerang (03-25-2020)
Old 03-25-2020, 01:39 AM   #12
steve99
Senior Member
 
steve99's Avatar
 
Join Date: Dec 2013
Drives: FT86
Location: Australia
Posts: 7,658
Thanks: 982
Thanked 4,753 Times in 2,846 Posts
Mentioned: 529 Post(s)
Tagged: 2 Thread(s)
Quote:
Originally Posted by powerwdp View Post
That solved the problem, I really appreciate it!

Can you describe a little about difference between row 1/2 with 7/8? Not sure why they switch those row for later map.

The ecu runs through thte rows in order from 1-8 , over the warm up period


I think they just made a mistake when the made the tune
steve99 is offline   Reply With Quote
The Following User Says Thank You to steve99 For This Useful Post:
powerwdp (03-26-2020)
Old 03-27-2020, 09:27 AM   #13
powerwdp
Member
 
Join Date: Oct 2018
Drives: 2018 Toyota 86
Location: NJ
Posts: 18
Thanks: 1
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by steve99 View Post
The ecu runs through thte rows in order from 1-8 , over the warm up period


I think they just made a mistake when the made the tune
The starting idle rev is a little bit low, I just rise it to 20/16/16/15/12/9/x. Hope that will work properly.
powerwdp is offline   Reply With Quote
Old 03-27-2020, 10:31 AM   #14
tomm.brz
Senior Member
 
Join Date: Jan 2017
Drives: brz 2017 hksv2
Location: italy
Posts: 1,350
Thanks: 319
Thanked 479 Times in 395 Posts
Mentioned: 16 Post(s)
Tagged: 0 Thread(s)
in those tables, the first 2 rows do not set the idle rpm, mostly just the initial throttle blip behaviour
rows 3-8 best to keep them stock for warm/hot start stability
tomm.brz is offline   Reply With Quote
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Unstable revs when switched to R/D from P powerwdp Engine, Exhaust, Transmission 3 03-22-2020 10:53 AM
Money Shifted my car, should I be nervous? norcalpb Engine, Exhaust, Transmission 11 12-31-2019 06:38 AM
Unstable idle when A/C cuts out paulca Engine, Exhaust, Transmission 14 10-24-2015 09:18 PM
2.5L with lower revs/more torque, or 2.0L with higher revs? Superhatch Engine, Exhaust, Transmission 124 08-28-2013 12:20 PM
Unstable feeling Toyobaru808 Suspension | Chassis | Brakes -- Sponsored by 949 Racing 11 06-28-2013 11:06 AM


All times are GMT -4. The time now is 03:18 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
User Alert System provided by Advanced User Tagging v3.3.0 (Lite) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Garage vBulletin Plugins by Drive Thru Online, Inc.