follow ft86club on our blog, twitter or facebook.
FT86CLUB
Ft86Club
Delicious Tuning
Register Garage Members List Calendar Search Today's Posts Mark Forums Read

Go Back   Toyota GR86, 86, FR-S and Subaru BRZ Forum & Owners Community - FT86CLUB > Technical Topics > Forced Induction

Forced Induction Turbo, Supercharger, Methanol, Nitrous


User Tag List
BT

Reply
 
Thread Tools Search this Thread
Old 07-31-2022, 08:22 PM   #4607
B T
Senior Member
 
Join Date: May 2015
Drives: 15 BRZ, 2020 C8, '70 Elky, 06 TBSS
Location: Mobile, Alabama
Posts: 461
Thanks: 169
Thanked 175 Times in 124 Posts
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quick shoutout for people looking for the Remote MAP sensor adapters, shipment just made it's way to CSG. I won't have any to offer on forum anymore.
B T is offline   Reply With Quote
The Following 3 Users Say Thank You to B T For This Useful Post:
ABQautoxer (08-03-2022), aKaGorganZola (07-31-2022), BAT_BRZ (08-06-2022)
Old 08-03-2022, 11:57 AM   #4608
Aztec
Lost in the twisties
 
Aztec's Avatar
 
Join Date: Sep 2014
Drives: 2014 BRZ Dark Gray Metallic
Location: Beaverton, OR
Posts: 657
Thanks: 428
Thanked 293 Times in 185 Posts
Mentioned: 33 Post(s)
Tagged: 2 Thread(s)
Quote:
Originally Posted by apatel471 View Post
Which oil cooler works the best with this kit? Not looking at the JR DROC. Thanks!


Sent from my iPhone using Tapatalk
I know you explicitly said not looking at the JR Dual kit, but.....It's great ;0

Quote:
Originally Posted by Colin86 View Post
Why not look at the JR dual radiator/oil cooler? It works great both on street and track, highly recommend. I have a gen1, so I swapped the oil lines so they didn't kink -but I've heard the gen2's don't have that issue.

2nded! Works great on street and track!
Been running it for the past year with zero issues. (better use of the space combining the two)
__________________
NEW CAR!🚨🏎️⛽
2014 BRZ: Edelbrock SC, CSG ZachTune, Jackson Radiator/Oil cooler, lightweight flywheel, CNT UEL, Berk OP/FP, Ark Grip Catback, Carbon fiber Driveshaft
Aztec's Build Thread
Aztec is offline   Reply With Quote
The Following User Says Thank You to Aztec For This Useful Post:
Jerr (08-05-2022)
Old 08-03-2022, 01:58 PM   #4609
B T
Senior Member
 
Join Date: May 2015
Drives: 15 BRZ, 2020 C8, '70 Elky, 06 TBSS
Location: Mobile, Alabama
Posts: 461
Thanks: 169
Thanked 175 Times in 124 Posts
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by apatel471 View Post
Which oil cooler works the best with this kit? Not looking at the JR DROC. Thanks!
I went with a Mishimoto, it ran it too cold, so got a smaller Setrab unit and it heatsoaked easily. Finally went back to the Mishimoto unit and got a higher temp thermostat on the oil bypass. Everything has been great since.
B T is offline   Reply With Quote
Old 08-04-2022, 11:05 AM   #4610
Jerr
Member
 
Jerr's Avatar
 
Join Date: Jan 2021
Drives: 2016 Scion FR-S / Edelbrock SC
Location: Colorado
Posts: 19
Thanks: 8
Thanked 21 Times in 7 Posts
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
I've been having a heck of a time diagnosing some weird idle characteristics on this kit. As Zach suggested, I cleaned my MAF sensor which would help for a bit, so I ended up deep cleaning the Edelbrock filter and entire airbox assembly. Got a new MAF o-ring and screws while I was at it.

I've now got a really weird issue where the car runs and drives great in most conditions, except at hot idle. When the radiator fans kick on, the idle dips to 500rpm and the car almost stalls, then idle jumps to 1500, and back and forth until the fans turn back off.

No CELs, no other issues that I'm aware of. Anyone have any ideas? Throttle body is new (under 5k miles). The logs don't show anything that looks like vacuum leaking either, trims are good.
Jerr is offline   Reply With Quote
Old 08-04-2022, 01:03 PM   #4611
FrickingReallySlow
Senior Member
 
Join Date: Jun 2021
Drives: 2015 FR-S
Location: San francisco
Posts: 291
Thanks: 105
Thanked 135 Times in 87 Posts
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by B T View Post
I went with a Mishimoto, it ran it too cold, so got a smaller Setrab unit and it heatsoaked easily. Finally went back to the Mishimoto unit and got a higher temp thermostat on the oil bypass. Everything has been great since.
Was this a 25 row or 19 row you used?
FrickingReallySlow is online now   Reply With Quote
Old 08-04-2022, 01:49 PM   #4612
dpfarr
Senior Member
 
Join Date: May 2020
Drives: BRZ ts
Location: SACRAMENTO
Posts: 604
Thanks: 327
Thanked 602 Times in 241 Posts
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by Jerr View Post
I've been having a heck of a time diagnosing some weird idle characteristics on this kit. As Zach suggested, I cleaned my MAF sensor which would help for a bit, so I ended up deep cleaning the Edelbrock filter and entire airbox assembly. Got a new MAF o-ring and screws while I was at it.

I've now got a really weird issue where the car runs and drives great in most conditions, except at hot idle. When the radiator fans kick on, the idle dips to 500rpm and the car almost stalls, then idle jumps to 1500, and back and forth until the fans turn back off.

No CELs, no other issues that I'm aware of. Anyone have any ideas? Throttle body is new (under 5k miles). The logs don't show anything that looks like vacuum leaking either, trims are good.
I had similar issue about idle. Turned out my MAF harness had a loose pin connection. I had an electrical code though.
dpfarr is offline   Reply With Quote
The Following User Says Thank You to dpfarr For This Useful Post:
Jerr (08-05-2022)
Old 08-04-2022, 03:53 PM   #4613
B T
Senior Member
 
Join Date: May 2015
Drives: 15 BRZ, 2020 C8, '70 Elky, 06 TBSS
Location: Mobile, Alabama
Posts: 461
Thanks: 169
Thanked 175 Times in 124 Posts
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by FrickingReallySlow View Post
Was this a 25 row or 19 row you used?
Pretty sure it's the 19 row
B T is offline   Reply With Quote
Old 08-05-2022, 07:36 PM   #4614
Jerr
Member
 
Jerr's Avatar
 
Join Date: Jan 2021
Drives: 2016 Scion FR-S / Edelbrock SC
Location: Colorado
Posts: 19
Thanks: 8
Thanked 21 Times in 7 Posts
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
@dpfarr It turns out Zach thinks it was a tune bug. I've triple-checked every harness and connection around the airbox, replaced nearly everything.

He flashed my tune from his version 6.5x to 7.5, and now everything is a lot more smooth. Still learning in the throttle but I believe he set the fan behavior for much tighter tolerances. It now fluctuates about 200rpm +/- which is totally acceptable. I had to force the AC on to get the fans to kick since my JR-DROC keeps the car pretty cool but so far so good.

If anyone else has this issue only when fans kick on it might be a bug.
Jerr is offline   Reply With Quote
Old 08-05-2022, 07:41 PM   #4615
Jerr
Member
 
Jerr's Avatar
 
Join Date: Jan 2021
Drives: 2016 Scion FR-S / Edelbrock SC
Location: Colorado
Posts: 19
Thanks: 8
Thanked 21 Times in 7 Posts
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by Aztec View Post
I know you explicitly said not looking at the JR Dual kit, but.....It's great ;0




2nded! Works great on street and track!
Been running it for the past year with zero issues. (better use of the space combining the two)
Thirded. I see oil temps between 180F (Winter) and 205F (Summer) daily driving, and 220F when my foot gets heavy in the canyons. Probably a bit lower than ideal but this thing can easily handle a track heat load.
Jerr is offline   Reply With Quote
The Following User Says Thank You to Jerr For This Useful Post:
Aztec (08-06-2022)
Old 08-05-2022, 09:26 PM   #4616
B T
Senior Member
 
Join Date: May 2015
Drives: 15 BRZ, 2020 C8, '70 Elky, 06 TBSS
Location: Mobile, Alabama
Posts: 461
Thanks: 169
Thanked 175 Times in 124 Posts
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by Jerr View Post
Thirded. I see oil temps between 180F (Winter) and 205F (Summer) daily driving, and 220F when my foot gets heavy in the canyons. Probably a bit lower than ideal but this thing can easily handle a track heat load.
that seems a bit high for normal cruising. I'm at about 172-180 on the interstate in dead summer on the gulf coast after heatsoaking. My track days get me up to about 235-240 in spring, summer and fall.
B T is offline   Reply With Quote
The Following User Says Thank You to B T For This Useful Post:
Aztec (08-06-2022)
Old 08-08-2022, 11:43 AM   #4617
ponggo
Member
 
Join Date: Apr 2020
Drives: 2012, toyota 86
Location: philippines
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
can anyone point me to the link to the map relocation kit?
ponggo is offline   Reply With Quote
Old 08-08-2022, 11:46 AM   #4618
ABQautoxer
Senior Member
 
ABQautoxer's Avatar
 
Join Date: Jun 2012
Drives: 2016 FRS / 2022 GR86
Location: Albuquerque, NM
Posts: 655
Thanks: 60
Thanked 197 Times in 141 Posts
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Just call and ask CSG or email them. I don't see them on the site.
__________________
TomR
ABQautoxer is offline   Reply With Quote
Old 08-08-2022, 06:32 PM   #4619
B T
Senior Member
 
Join Date: May 2015
Drives: 15 BRZ, 2020 C8, '70 Elky, 06 TBSS
Location: Mobile, Alabama
Posts: 461
Thanks: 169
Thanked 175 Times in 124 Posts
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by ponggo View Post
can anyone point me to the link to the map relocation kit?
They just got them in for the first time recently. Give them a call.
B T is offline   Reply With Quote
Old 08-21-2022, 12:49 PM   #4620
Jerr
Member
 
Jerr's Avatar
 
Join Date: Jan 2021
Drives: 2016 Scion FR-S / Edelbrock SC
Location: Colorado
Posts: 19
Thanks: 8
Thanked 21 Times in 7 Posts
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Hey friends,

I've been having really strange idle issues specifically on radiator fan kick that I can't seem to diagnose. I tried a new tune which sort of band-aided the problem, but I didn't have this issue before on my tune which leads me to believe it's a mechanical or electrical issue.

The behavior: when the car is hot and idling and the thermostat calls for fans to kick on, the idle dips from the normal ~900 to 450 (almost stalling) and back to 1300, then back down to 450, over and over until the fans turn off. When the fans are off, everything goes back to normal. While this is occuring, I can see STFT jump around from -2 to +20 and AFR going all over the place. Interestingly, if I manually turn on the radiator fans by turning on the AC, the car compensates properly and idle sits at around 1000 stable. This problem is able to be replicated.

Things I have replaced/done:
-Checked for vacuum leaks (tune logs also show none)
-New battery optima yellowtop
-Checked that alternator is working (battery is charging properly)
-New OEM MAF sensor
-New OEM front O2
-New OEM PCV Valve
-Throttle body is still fairly new since ~1 year ago
-Air intake/filter parts completely cleaned
-Fresh flash of stable tune from when car was originally "dialed in"

I noticed in the logs that right as the fans kick on and before the idle actually dips, the MAF reading in g/s jumps up from 2.5 to about the 4.8 range, and the MAP reading goes from .3bar (stable idle) to .46 which is counterintuitive as the RPM is dropping, therefore the boost should be lower...?

Does anyone have any ideas of what might physically be wrong? I figured maybe fans drawing too much amperage but the same issue would also persist when AC was turned on, right?

Thanks all!

Last edited by Jerr; 08-21-2022 at 01:18 PM.
Jerr is offline   Reply With Quote
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Vortech Owner Thread & Setup Questions reyruiz191 Forced Induction 340 05-17-2022 12:44 PM
Edelbrock E-Force Supercharger itsibarra Forced Induction 938 07-31-2021 04:48 PM
Most annoyingly over-asked questions on FT86 forums mit_peid Off-Topic Lounge [WARNING: NO POLITICS] 36 01-16-2014 02:48 PM
Brz Info/Specs (helpful info for questions asked often) Gaen BRZ First-Gen (2012+) -- General Topics 0 05-24-2012 10:09 PM


All times are GMT -4. The time now is 12:59 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
User Alert System provided by Advanced User Tagging v3.3.0 (Lite) - vBulletin Mods & Addons Copyright © 2022 DragonByte Technologies Ltd.

Garage vBulletin Plugins by Drive Thru Online, Inc.