follow ft86club on our blog, twitter or facebook.
FT86CLUB
Ft86Club
Speed By Design
Register Garage Members List Calendar Search Today's Posts Mark Forums Read

Go Back   Scion FR-S Forum | Subaru BRZ Forum | Toyota 86 GT 86 Forum | AS1 Forum - FT86CLUB > Technical Topics > Issues | Warranty | Recalls / TSB

Issues | Warranty | Recalls / TSB Problems, issues, recalls, TSBs


User Tag List

Reply
 
Thread Tools Search this Thread
Old 04-17-2019, 02:04 AM   #1
kyle32dean
Junior Member
 
Join Date: Apr 2019
Drives: 2013 Subaru BRZ (silver)
Location: Boise ID
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Tach Gone Crazy! Need Help

Hello everyone, I am super new. Just bought my BRZ and this has been a dream car for a long time. It is a 2013 BRZ with manual transmission. The issue I have been having is that about 50% of the time when I start the car up the idle RPM reads really high (like above 4500 RPM). Its idling where it should be but it's reading very high. As I rev it up it continues to climb way past redline and sometimes around to the ODO. I have been doing a lot of research and can't find anyone that is having the same issue. Also the other half of the time when it reads correctly it seems to be dead on. It seems strange that none of the other gauges are messed up at all. IDK what to do. please help.

The first pic is at idle and the second pic is about mid rpm. (obviously not 12,000)
Attached Images
  
kyle32dean is offline   Reply With Quote
Old 04-17-2019, 08:32 AM   #2
msaikhan
Member
 
Join Date: Jun 2018
Drives: frs
Location: arlingtong va
Posts: 92
Thanks: 18
Thanked 31 Times in 20 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by kyle32dean View Post
Hello everyone, I am super new. Just bought my BRZ and this has been a dream car for a long time. It is a 2013 BRZ with manual transmission. The issue I have been having is that about 50% of the time when I start the car up the idle RPM reads really high (like above 4500 RPM). Its idling where it should be but it's reading very high. As I rev it up it continues to climb way past redline and sometimes around to the ODO. I have been doing a lot of research and can't find anyone that is having the same issue. Also the other half of the time when it reads correctly it seems to be dead on. It seems strange that none of the other gauges are messed up at all. IDK what to do. please help.

The first pic is at idle and the second pic is about mid rpm. (obviously not 12,000)
i'm gonna take a guess on this.
I think the needle is just misaligned or loose from it's mounting.
You can probably take it apart and align the needle.

or just replace it as a whole assembly.
msaikhan is offline   Reply With Quote
Old 04-17-2019, 12:25 PM   #3
humfrz
Senior Member
 
Join Date: May 2013
Drives: 2013 FR-S, white, MT
Location: Puyallup, WA
Posts: 20,637
Thanks: 14,720
Thanked 18,213 Times in 10,068 Posts
Mentioned: 483 Post(s)
Tagged: 2 Thread(s)
Welcome to the group!

Oh, I hope the engine isn't running at the indicated RPM?

Assuming it's not, I reckon a tune-er or the dealership should take a look see and see what is whacked out.

Or you could try disconnecting the battery for a minute and hook it back up, to see if the ECU will right itself.


humfrz
humfrz is online now   Reply With Quote
Old 04-17-2019, 12:57 PM   #4
Sportsguy83
I Love custom Turbo kits
 
Sportsguy83's Avatar
 
Join Date: Mar 2012
Drives: Limited BRZ
Location: Miami
Posts: 10,707
Thanks: 19,886
Thanked 8,251 Times in 4,325 Posts
Mentioned: 436 Post(s)
Tagged: 12 Thread(s)
Garage
Quote:
Originally Posted by kyle32dean View Post
Hello everyone, I am super new. Just bought my BRZ and this has been a dream car for a long time. It is a 2013 BRZ with manual transmission. The issue I have been having is that about 50% of the time when I start the car up the idle RPM reads really high (like above 4500 RPM).
Do the RPMs stay high all the time after you start the car or settle later? Does turning car off/on fix it?

Connect an OBD2 cheap adapter and see if the RPMs show correctly on the adapter vs. the cluster. If that is the case, you probably need a new cluster (ECU output is the right RPMs but the cluster is not delivering them right).

I rule out a misaligned needle because in that case you'd have a faulty RPM reading all the time, not 50% of the time.

If it's not isolated to the cluster, you have an electrical problem and those can be a pita to find.
Sportsguy83 is offline   Reply With Quote
Old 04-17-2019, 01:22 PM   #5
BirdTRD
analytical mooncalf
 
BirdTRD's Avatar
 
Join Date: Sep 2013
Drives: 2014 Supercharged SSM BRZ Limited
Location: Baltimore, MD
Posts: 745
Thanks: 613
Thanked 736 Times in 363 Posts
Mentioned: 22 Post(s)
Tagged: 0 Thread(s)
Garage
There appears to be tool marks above the speedometer so I would suspect that cluster has been out for one reason or another. You may want to look into that, maybe there's a loose connection back there.
BirdTRD is offline   Reply With Quote
The Following User Says Thank You to BirdTRD For This Useful Post:
Sportsguy83 (04-17-2019)
Old 04-17-2019, 06:56 PM   #6
RZNT4R
Professional Mechanic
 
Join Date: Apr 2010
Drives: 2017 86 6MT Oceanic
Location: Quebec, Canada
Posts: 185
Thanks: 5
Thanked 107 Times in 62 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Most modern clusters are on the canbus, so it's possible to read internal faults, command the stepper motors and test display segments.

Checking that would be my initial instinct.
RZNT4R is offline   Reply With Quote
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
tach starts below 0 aquaman Electronics | Audio | NAV | Infotainment 17 07-01-2016 02:47 PM
Crazy Good Deal or just Crazy MJones_RB Subaru BRZ General Forum 31 05-06-2016 03:22 PM
HELP: Need Tach Signal!! Lil Abner Electronics | Audio | NAV | Infotainment 39 02-24-2016 09:59 PM
Cant see the top of my tach... MadFRS Scion FR-S / Toyota 86 GT86 General Forum 31 07-29-2013 04:11 PM
BRZ tach to FRS? lavisxice Cosmetic Modification (Interior/Exterior/Lighting) 7 04-01-2013 03:48 PM


All times are GMT -4. The time now is 02:13 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Garage vBulletin Plugins by Drive Thru Online, Inc.