follow ft86club on our blog, twitter or facebook. Interested in the FT-1? Check out FT1Club
FT86CLUB
Ft86Club
WORKS
Register Garage Members List Calendar Search Today's Posts Mark Forums Read

Go Back   Scion FR-S Forum | Subaru BRZ Forum | Toyota 86 GT 86 Forum | AS1 Forum - FT86CLUB > Technical Topics > Suspension | Chassis | Brakes

Suspension | Chassis | Brakes Relating to suspension, chassis, and brakes.

User Tag List

Reply
 
Thread Tools Search this Thread
Old 01-11-2013, 01:05 AM   #1
sw20kosh
Senior Member
 
Join Date: Jul 2012
Drives: 2013 Black FR-S
Location: SF
Posts: 2,389
Thanks: 693
Thanked 1,335 Times in 664 Posts
Mentioned: 97 Post(s)
Tagged: 1 Thread(s)
Whiteline Com-c top mounts

I did a search but couldn't find it.

I remember reading some people having big problems with these? Clunking sounds etc. Is this still the case?
sw20kosh is offline   Reply With Quote
Old 01-11-2013, 01:19 AM   #2
whataboutbob
AutoX-10/10ths every run
 
whataboutbob's Avatar
 
Join Date: Jun 2012
Drives: 2013 Scion FR-S AT Firestorm
Location: San Marcos, CA, USA
Posts: 1,767
Thanks: 2,812
Thanked 1,025 Times in 590 Posts
Mentioned: 54 Post(s)
Tagged: 0 Thread(s)
Garage
I talked to the Whiteline North America rep a while back. It was a limited number of units, all of which will be covered under warranty. They stopped production to eliminate the problem.

I've got a set on order, and I'll be posting my experiences once I get them installed.
__________________

[ San Diego SCCA Solo2 #86 SM | Whiteline | Innovate Motorsports | Winmax | Delicioustuning | Counterspacegarage | Raceseng | CuscoUSA | RS-R USA | Build thread: Here ]
whataboutbob is offline   Reply With Quote
The Following User Says Thank You to whataboutbob For This Useful Post:
Mo707 (01-11-2013)
Old 01-11-2013, 11:44 AM   #3
Turn in Concepts
Senior Member
 
Turn in Concepts's Avatar
 
Join Date: Oct 2012
Drives: BRZ
Location: Cincinnati, OH
Posts: 332
Thanks: 15
Thanked 121 Times in 67 Posts
Mentioned: 23 Post(s)
Tagged: 0 Thread(s)
We had some problems with them back a year ago or so, but they seem to be better since.

Tony
Turn in Concepts is offline   Reply With Quote
Old 01-13-2013, 01:34 PM   #4
Smudgeous
Senior Member
 
Smudgeous's Avatar
 
Join Date: Mar 2012
Drives: 2013 WRB 6MT BRZ Ltd.
Location: Orlando, FL
Posts: 232
Thanks: 67
Thanked 72 Times in 51 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Garage
Quote:
Originally Posted by Turn in Concepts View Post
We had some problems with them back a year ago or so, but they seem to be better since.

Tony
I've had 2 sets both result in the same issues. The second pair was double-checked that nothing was wrong before installing them (no notchiness, bearings spun fine), but after driving around on them for awhile, I got the same issues with the car making a lot of clunking while turning the wheel.

For the record, the first ones I got were in August, with the replacements in mid September. Unfortunately during installation the second time, I let the wife help out with the re-tightening of the strut bolts with my torque wrench, with the result basically the same as Cobrabyte's recent post

I suppose I could always try to contact Whiteline about it since it's still a problem that happened regardless of the shearing of the bolt, but I'm not sure whether I want to try a third time or just call it quits and throw back on the stockers..
Smudgeous is offline   Reply With Quote
Old 01-16-2013, 05:12 PM   #5
Smudgeous
Senior Member
 
Smudgeous's Avatar
 
Join Date: Mar 2012
Drives: 2013 WRB 6MT BRZ Ltd.
Location: Orlando, FL
Posts: 232
Thanks: 67
Thanked 72 Times in 51 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Garage
As a follow-up to my last post, I just got off the phone with Jan, who told me that they did have a bad batch of bearings from their last manufacturing run that they're aware of and trying to rectify. He said they're currently expecting a replacement batch in around the end of February, and already had my name down on a list of people who'd called in with problems. They'll be working on getting everyone replacement (or in my case, replacement replacement) Com Cs around the beginning of March.

For those curious of my own plight, he additionally told me that my sheared bolt would not be a problem, and that I can still return them once I receive the new ones.
Smudgeous is offline   Reply With Quote
The Following 2 Users Say Thank You to Smudgeous For This Useful Post:
Calum (01-16-2013), whataboutbob (01-16-2013)
Old 01-17-2013, 04:48 PM   #6
ATL BRZ
HPDE Instructor
 
ATL BRZ's Avatar
 
Join Date: Jun 2012
Drives: BRZ
Location: Atlanta
Posts: 2,850
Thanks: 2,662
Thanked 2,443 Times in 1,158 Posts
Mentioned: 62 Post(s)
Tagged: 3 Thread(s)
Quote:
Originally Posted by Smudgeous View Post
As a follow-up to my last post, I just got off the phone with Jan, who told me that they did have a bad batch of bearings from their last manufacturing run that they're aware of and trying to rectify. He said they're currently expecting a replacement batch in around the end of February, and already had my name down on a list of people who'd called in with problems. They'll be working on getting everyone replacement (or in my case, replacement replacement) Com Cs around the beginning of March.

For those curious of my own plight, he additionally told me that my sheared bolt would not be a problem, and that I can still return them once I receive the new ones.

That is my understanding as well, I've been emailing Jan back and forth myself awaiting the upcoming solution. Right now I'm still running the stock top mounts. I have a brand new set of com-c's that they sent me sitting around and I will send them back once the replacements get in. Jan assured me that it would be a complimentary replacement, which I appreciate.

Here is my post explaining the issue with the top mounts: http://www.ft86club.com/forums/showp...&postcount=175
__________________
ATL BRZ is offline   Reply With Quote
Old 02-12-2013, 08:04 PM   #7
sw20kosh
Senior Member
 
Join Date: Jul 2012
Drives: 2013 Black FR-S
Location: SF
Posts: 2,389
Thanks: 693
Thanked 1,335 Times in 664 Posts
Mentioned: 97 Post(s)
Tagged: 1 Thread(s)
Any update on these from Whiteline? Would love to get these new revised ones on the car!
sw20kosh is offline   Reply With Quote
Old 02-19-2013, 06:00 PM   #8
ATL BRZ
HPDE Instructor
 
ATL BRZ's Avatar
 
Join Date: Jun 2012
Drives: BRZ
Location: Atlanta
Posts: 2,850
Thanks: 2,662
Thanked 2,443 Times in 1,158 Posts
Mentioned: 62 Post(s)
Tagged: 3 Thread(s)
Bump for update. Anyone talk to Jan from WL-US?
__________________
ATL BRZ is offline   Reply With Quote
Old 02-19-2013, 07:14 PM   #9
Calum
That Guy
 
Join Date: Dec 2011
Drives: 2013 asphalt FRS MT
Location: Halifax, Nova Scotia
Posts: 3,739
Thanks: 3,550
Thanked 2,094 Times in 1,087 Posts
Mentioned: 62 Post(s)
Tagged: 1 Thread(s)
I've inquired with a couple vendors about the top hats. Everyone seems to say the new batch should be available ~ march.
Calum is offline   Reply With Quote
Old 02-19-2013, 07:54 PM   #10
jamal
Senior Member
 
jamal's Avatar
 
Join Date: Nov 2011
Drives: Legacy GT
Location: compton
Posts: 281
Thanks: 7
Thanked 136 Times in 84 Posts
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by ATL BRZ View Post
Bump for update. Anyone talk to Jan from WL-US?
Yep. A couple weeks ago I heard mid march.
jamal is offline   Reply With Quote
Old 02-19-2013, 08:23 PM   #11
Turn in Concepts
Senior Member
 
Turn in Concepts's Avatar
 
Join Date: Oct 2012
Drives: BRZ
Location: Cincinnati, OH
Posts: 332
Thanks: 15
Thanked 121 Times in 67 Posts
Mentioned: 23 Post(s)
Tagged: 0 Thread(s)
I've been watching, and they are out of stock everywhere (or at least all the common places).
Turn in Concepts is offline   Reply With Quote
Old 03-05-2013, 04:46 PM   #12
ATL BRZ
HPDE Instructor
 
ATL BRZ's Avatar
 
Join Date: Jun 2012
Drives: BRZ
Location: Atlanta
Posts: 2,850
Thanks: 2,662
Thanked 2,443 Times in 1,158 Posts
Mentioned: 62 Post(s)
Tagged: 3 Thread(s)
Just got an email from Jan @ Whiteline US. The new batch of top mounts are in and should be shipping out now to warranty customers.
__________________
ATL BRZ is offline   Reply With Quote
The Following User Says Thank You to ATL BRZ For This Useful Post:
Calum (03-05-2013)
Old 03-12-2013, 10:01 PM   #13
ATL BRZ
HPDE Instructor
 
ATL BRZ's Avatar
 
Join Date: Jun 2012
Drives: BRZ
Location: Atlanta
Posts: 2,850
Thanks: 2,662
Thanked 2,443 Times in 1,158 Posts
Mentioned: 62 Post(s)
Tagged: 3 Thread(s)
FINALLY received my warranty replacement Whiteline Com-C top mounts. My originals were removed after one day of rattle & pop filled driving due to bad bearings and/or suspension geometry. I took some comparison photos of the new vs old top mounts to show what's different in this run that will hopefully solve the issues with deforming rubber around the bearings when turning, and some folks had clunking noises too

Bottom side comparison, you can clearly see a different bearing insert in the middle, not much else different


New top side includes some dust covers.


Without the dust covers on top. Note the different inner bearings on top


This is where I'm still concerned about these. In my experience with the original Com-C's, over every slight bump or deviation, I could hear the upper spring perches colliding with the collar around the bottom of the top mounts, circled below in blue. I presumed this was due to bad geometry due to the lack of a conical washer on the upper spring perch on the BRZ; we have a welded flat washer, unlike the WRX which uses a separate conical washer to ensure proper mating with the inner bearing at the increased negative camber angles. When I removed the original Com-C's to swap back to stock, my upper spring perches had marks all over them from colliding with the collar on the bottom of the Com-C's. They were installed exactly as instructed and spun freely around the strut before installing back into the car.



The new top mounts have the exact same collar depth, which has me concerned about them. I will be emailing my concerns and findings to Jan at Whiteline-US and try to get more info about what has changed in this new batch to prevent contact between the bottom collar of the Com-C's and the upper spring perch.
__________________

Last edited by ATL BRZ; 03-12-2013 at 10:55 PM.
ATL BRZ is offline   Reply With Quote
The Following 3 Users Say Thank You to ATL BRZ For This Useful Post:
BRZranger (03-22-2013), Calum (03-14-2013), enjoyminutemaid (03-14-2013)
Old 03-14-2013, 04:05 PM   #14
ATL BRZ
HPDE Instructor
 
ATL BRZ's Avatar
 
Join Date: Jun 2012
Drives: BRZ
Location: Atlanta
Posts: 2,850
Thanks: 2,662
Thanked 2,443 Times in 1,158 Posts
Mentioned: 62 Post(s)
Tagged: 3 Thread(s)
Jan @ Whiteline US responded to my inquiry

Quote:
The durometer of the rubber has been stepped up to reduce deflection under load.

The top hats have been road tested on cars in Australia, with zero problems to date.
ATL BRZ is offline   Reply With Quote
The Following 2 Users Say Thank You to ATL BRZ For This Useful Post:
Calum (03-14-2013), enjoyminutemaid (03-14-2013)
Old 03-14-2013, 07:19 PM   #15
SWPBRZ415
Member
 
Join Date: Jul 2012
Drives: brz
Location: SF
Posts: 37
Thanks: 1
Thanked 6 Times in 4 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Installed my set on Monday, so far so good. Gonna go give it a good run this weekend in the mountains, hope it'll be okay.
SWPBRZ415 is offline   Reply With Quote
Old 03-14-2013, 08:20 PM   #16
ATL BRZ
HPDE Instructor
 
ATL BRZ's Avatar
 
Join Date: Jun 2012
Drives: BRZ
Location: Atlanta
Posts: 2,850
Thanks: 2,662
Thanked 2,443 Times in 1,158 Posts
Mentioned: 62 Post(s)
Tagged: 3 Thread(s)
Quote:
Originally Posted by SWPBRZ415 View Post
Installed my set on Monday, so far so good. Gonna go give it a good run this weekend in the mountains, hope it'll be okay.
No noises over bumps or while turning? Are you using the stock springs or aftermarket?
__________________
ATL BRZ is offline   Reply With Quote
Old 03-14-2013, 09:03 PM   #17
Racecomp Engineering
 
Join Date: Nov 2011
Drives: 2013 BRZ, 2012 Paris Di2 & 2011 WRX
Location: Severn, MD
Posts: 2,595
Thanks: 738
Thanked 2,359 Times in 1,070 Posts
Mentioned: 168 Post(s)
Tagged: 1 Thread(s)
Send a message via AIM to Racecomp Engineering
One thing we noticed after getting the NEW GR chassis WRX/STI versions in is the bearing is the KOYO brand , which btw is the same that STI uses for the group-n mounts. These are OEM level quality. THAT , my friends is ALSO good news and awesome on Whiteline's part to make this right.

Yay.

Myles
Racecomp Engineering is offline   Reply With Quote
The Following 2 Users Say Thank You to Racecomp Engineering For This Useful Post:
ATL BRZ (03-15-2013), Calum (03-14-2013)
Old 03-15-2013, 05:57 AM   #18
enjoyminutemaid
Senior Member
 
enjoyminutemaid's Avatar
 
Join Date: Jun 2012
Drives: Subaru BRZ Limited WRB Manual
Location: RI/MA
Posts: 212
Thanks: 185
Thanked 44 Times in 28 Posts
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
I feel like an idiot for asking this, but do camber plates compliment the tophats, or do they replace them?
enjoyminutemaid is offline   Reply With Quote
Old 03-15-2013, 06:05 AM   #19
Calum
That Guy
 
Join Date: Dec 2011
Drives: 2013 asphalt FRS MT
Location: Halifax, Nova Scotia
Posts: 3,739
Thanks: 3,550
Thanked 2,094 Times in 1,087 Posts
Mentioned: 62 Post(s)
Tagged: 1 Thread(s)
Quote:
Originally Posted by enjoyminutemaid View Post
I feel like an idiot for asking this, but do camber plates compliment the tophats, or do they replace them?
Replace.
Calum is offline   Reply With Quote
Old 03-15-2013, 08:52 AM   #20
Racecomp Engineering
 
Join Date: Nov 2011
Drives: 2013 BRZ, 2012 Paris Di2 & 2011 WRX
Location: Severn, MD
Posts: 2,595
Thanks: 738
Thanked 2,359 Times in 1,070 Posts
Mentioned: 168 Post(s)
Tagged: 1 Thread(s)
Send a message via AIM to Racecomp Engineering
Right. Camber plates are a type of tophat.

- drew
Racecomp Engineering is offline   Reply With Quote
Old 03-15-2013, 12:23 PM   #21
SWPBRZ415
Member
 
Join Date: Jul 2012
Drives: brz
Location: SF
Posts: 37
Thanks: 1
Thanked 6 Times in 4 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by ATL BRZ View Post
No noises over bumps or while turning? Are you using the stock springs or aftermarket?
Nope no noises, running RCE yellows. -1.5 camber all around on 18x8.5.
SWPBRZ415 is offline   Reply With Quote
The Following 2 Users Say Thank You to SWPBRZ415 For This Useful Post:
ATL BRZ (03-15-2013), console_cowboy (08-02-2013)
Old 03-17-2013, 08:33 PM   #22
enjoyminutemaid
Senior Member
 
enjoyminutemaid's Avatar
 
Join Date: Jun 2012
Drives: Subaru BRZ Limited WRB Manual
Location: RI/MA
Posts: 212
Thanks: 185
Thanked 44 Times in 28 Posts
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by SWPBRZ415 View Post
Nope no noises, running RCE yellows. -1.5 camber all around on 18x8.5.
What are you using for rear camber adjustment?
enjoyminutemaid is offline   Reply With Quote
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
upgraded mounts? 7thgear Engine, Exhaust, Transmission 19 01-11-2013 11:31 PM
Buyer Beware: Motor Mounts cobrabyte Engine, Exhaust, Transmission 5 01-04-2013 08:14 PM
Autocross Camera Mounts? fritzy Subaru BRZ General Forum 7 08-03-2012 09:48 PM
SEAT BRACKETS / SIDE MOUNTS - Planted Technology - Font Motorsports Font Motorsports Interior Parts (Incl. Lighting) 2 07-03-2012 05:43 PM
Dash Mounts for gadgets smbrm Cosmetic Modification (Interior/Exterior/Lighting) 0 06-28-2012 06:07 PM


All times are GMT -5. The time now is 11:08 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage vBulletin Plugins by Drive Thru Online, Inc.