follow ft86club on our blog, twitter or facebook.
FT86CLUB
Ft86Club
Speed By Design
Register Garage Members List Calendar Search Today's Posts Mark Forums Read

Go Back   Scion FR-S Forum | Subaru BRZ Forum | Toyota 86 GT 86 Forum | AS1 Forum - FT86CLUB > Technical Topics > Forced Induction

Forced Induction Turbo, Supercharger, Methanol, Nitrous


User Tag List

Reply
 
Thread Tools Search this Thread
Old 12-01-2019, 05:28 PM   #3305
B T
Senior Member
 
Join Date: May 2015
Drives: 15 BRZ, 70 Camino, 06 TBSS, 20 Vett
Location: Mobile, Alabama
Posts: 234
Thanks: 90
Thanked 55 Times in 45 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
just got the heads off, with the exception of two bent exhaust valves, they're all good!
B T is offline   Reply With Quote
The Following User Says Thank You to B T For This Useful Post:
tomm.brz (12-02-2019)
Old 12-01-2019, 08:44 PM   #3306
Colin86
Member
 
Join Date: Jun 2016
Drives: 86
Location: OH
Posts: 92
Thanks: 14
Thanked 43 Times in 28 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by B T View Post
Kiske, close, but I think it was cylinder #2, LH side front from driver seat.
FWIW I met the team at Dynosty in KY and they seem like a strong group. If I were building a motor I'd consider them. Keep us posted if you could, I'll be curious what you go with and your experience in case my stock motor ever lets go.
Colin86 is offline   Reply With Quote
Old 12-01-2019, 11:33 PM   #3307
B T
Senior Member
 
Join Date: May 2015
Drives: 15 BRZ, 70 Camino, 06 TBSS, 20 Vett
Location: Mobile, Alabama
Posts: 234
Thanks: 90
Thanked 55 Times in 45 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by Colin86 View Post
Keep us posted if you could, I'll be curious what you go with and your experience in case my stock motor ever lets go.
I guess I forgot to mention the build.

IAG Stage 2.5 Block,
Compression dropped to 12.4 with slightly thicker gasket
Ferrea +1 mm over intake/exhaust Comp Plus valves
Ferrea single valve spring kit
GSC guides and seals
Perrin motor mounts (I found the passenger side frame rail rubbed by the engine)

They had the block to me within a week of ordering. It's really hard to get them on the phone though.
B T is offline   Reply With Quote
Old 12-02-2019, 03:41 PM   #3308
itsaBRZ
Member
 
Join Date: Oct 2017
Drives: 2015 Subaru BRZ Aozora
Location: Canada
Posts: 27
Thanks: 3
Thanked 1 Time in 1 Post
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by kev0 View Post
How many miles since replacing the front o2 sensor? Did you check header for exhaust leak? The codes may come back after 20 or so miles. If you pressure/smoke tested and found absolutely no leaks, it could be in the tune.
Yes, no leaks at the header and you sir are correct... the P1170 and P117B (Port & Direction Injection failed codes) have since come back even with the new O2 sensor.

I'm running the stock Edelbrock carb tune, is there a possibility for some reason it doesn't work on my car?
itsaBRZ is offline   Reply With Quote
Old 12-02-2019, 03:44 PM   #3309
itsaBRZ
Member
 
Join Date: Oct 2017
Drives: 2015 Subaru BRZ Aozora
Location: Canada
Posts: 27
Thanks: 3
Thanked 1 Time in 1 Post
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by toast View Post
Are your fuel trims still through the roof?

Thinking about everything that gets removed/reinstalled for this we should be able to narrow this down. High fuel trims are generally a vacuum leak but all these other weird things showing up make me wonder if your ECU is connected and grounded. Check the four plugs on the ECU and make sure they are fully seated. I would actually pull all four off and check to make sure none of the pins are damaged before reconnecting everything. The ECU grounds to the block via the bottom bolt of the three that hold it on. I actually added an 8 gauge wire going right from the ECU to a bolt in an open hole on the block just to make sure.
I'll double check all of those 4 plugs are fully seated to the ECU and yes all 3 bolts are connected to the ECU. The bottom bolt was a paint in the ass to get in because of the waterpump hoses. When you have a spare moment, would you please take a picture of where you grounded the wire from the ECU bolt? I'd appreciate it and thanks.
itsaBRZ is offline   Reply With Quote
Old 12-03-2019, 04:39 PM   #3310
B T
Senior Member
 
Join Date: May 2015
Drives: 15 BRZ, 70 Camino, 06 TBSS, 20 Vett
Location: Mobile, Alabama
Posts: 234
Thanks: 90
Thanked 55 Times in 45 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Has anyone had experience with the Koyorad or CF Racing radiators with the edelbrock?
B T is offline   Reply With Quote
Old 12-06-2019, 02:54 PM   #3311
shr133
Member
 
shr133's Avatar
 
Join Date: Nov 2015
Drives: 2013 FRS
Location: WISCONSIN
Posts: 84
Thanks: 30
Thanked 21 Times in 17 Posts
Mentioned: 14 Post(s)
Tagged: 0 Thread(s)
Garage
I don't know why I can't find this? What is the boost for the 3" pulley.
__________________
Enkei TS9 18 X 8, Michelin Sport 4S 225 40 18, Flex Fuel, AREV short ram, KN, snorkel mod with cold air duct, P & L header, Nameless front pipe, V1 cat back, Aluminum Driveshaft, pvc delete, med duck bill, KW V3, Whiteline 20 and 18 mm bars, Buddy Club and SPL control arms, Toe Arms, motor and trans mounts, Whiteline bushings, SHR stage II tune.
shr133 is offline   Reply With Quote
Old 12-07-2019, 06:11 PM   #3312
Kiske
Senior Member
 
Kiske's Avatar
 
Join Date: Jun 2013
Drives: RX-7 / BRZ
Location: North KCMO
Posts: 1,489
Thanks: 552
Thanked 1,057 Times in 508 Posts
Mentioned: 22 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by shr133 View Post
I don't know why I can't find this? What is the boost for the 3" pulley.
3" = 15psi
2.6" = 20psi
https://www.ft86club.com/forums/show...&postcount=329
__________________

//2013 World Rally Blue BRZ Limited FBM Turbo
//2018 Crystal White Pearl BRZ Ts Supercharged
Kiske is offline   Reply With Quote
The Following User Says Thank You to Kiske For This Useful Post:
shr133 (12-12-2019)
Old 12-09-2019, 06:33 PM   #3313
B T
Senior Member
 
Join Date: May 2015
Drives: 15 BRZ, 70 Camino, 06 TBSS, 20 Vett
Location: Mobile, Alabama
Posts: 234
Thanks: 90
Thanked 55 Times in 45 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Anyone know what temperature the heads get upto? Was looking into a high temp Teflon gasket between the heads and supercharger. It's only good upto 250 deg F
B T is offline   Reply With Quote
Old 12-12-2019, 09:25 PM   #3314
shr133
Member
 
shr133's Avatar
 
Join Date: Nov 2015
Drives: 2013 FRS
Location: WISCONSIN
Posts: 84
Thanks: 30
Thanked 21 Times in 17 Posts
Mentioned: 14 Post(s)
Tagged: 0 Thread(s)
Garage
Quote:
Originally Posted by Kiske View Post
Guess I won't be using the 3" pulley with stock rods.........
__________________
Enkei TS9 18 X 8, Michelin Sport 4S 225 40 18, Flex Fuel, AREV short ram, KN, snorkel mod with cold air duct, P & L header, Nameless front pipe, V1 cat back, Aluminum Driveshaft, pvc delete, med duck bill, KW V3, Whiteline 20 and 18 mm bars, Buddy Club and SPL control arms, Toe Arms, motor and trans mounts, Whiteline bushings, SHR stage II tune.
shr133 is offline   Reply With Quote
Old 12-17-2019, 06:17 PM   #3315
djenousis
Member
 
Join Date: Jun 2015
Drives: 2015
Location: Torrance, CA
Posts: 21
Thanks: 9
Thanked 1 Time in 1 Post
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Garage
Quote:
Originally Posted by itsaBRZ View Post
Yes, no leaks at the header and you sir are correct... the P1170 and P117B (Port & Direction Injection failed codes) have since come back even with the new O2 sensor.

I'm running the stock Edelbrock carb tune, is there a possibility for some reason it doesn't work on my car?
Do you have any updates? You are one of the few people I've found that is having an almost identical experience.
__________________
2015 Subaru BRZ
djenousis is offline   Reply With Quote
Old 12-19-2019, 03:50 PM   #3316
BA9092
Captain Slow
 
BA9092's Avatar
 
Join Date: Jun 2018
Drives: '18 BRZ Limited PP 6MT ISM
Location: DFW area
Posts: 202
Thanks: 122
Thanked 91 Times in 39 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
I've been keeping up with the posts for a few months now, but haven't read EVERY single one of them.

I'm about to start the install this weekend. I have the instructions from Edelbrock and keeping this video (https://youtu.be/Vk4pFiWOMPQ) handy as well.

Any tips, tricks or cautions regarding the 2017+ model years?
BA9092 is online now   Reply With Quote
Old 12-25-2019, 04:30 AM   #3317
kev0
AUTOMATIC TRANNY
 
Join Date: Feb 2018
Drives: 2014 FRS AT
Location: Chicago, IL
Posts: 353
Thanks: 166
Thanked 58 Times in 44 Posts
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
For those who have had a faulty bypass actuator, what were some symptoms? I suspect mine to be failing. P0171, P1170 and P117B codes.

@djenousis @itsaBRZ did you guys ever find a fix to your problem?
kev0 is offline   Reply With Quote
Old 12-26-2019, 12:58 AM   #3318
Smaay
Member
 
Join Date: Feb 2019
Drives: 2013 FRS
Location: Lancaster
Posts: 26
Thanks: 0
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Sorry for making a double post but the answers I got really have me worried about experience in FI


Something is wrong S/C
I have the Edelbrock S/C and the car has been running fine for almost a year. Well last week I got on it and it shuttered and the CEL flashed but no code was set.



Then the other day I had the same issue and then got a 0300 and 0301. I have 92k miles on the odometer so i finally installed the HKS sparkplugs. everything in the install was fine, but now the car run like absolute shit.



There is no power, its misfiring, and according to my gauges, it seems like the AF is not getting richer going into boost.



one thing that did happen is while turning a ratchet, I touched the positive battery terminal and fried the right side fuse link. The ECU was disconnected when this happened. I didnt realize I killed it until i went in and had no power. I moved that cable to the left side fuse link and got all my power back.


the spark plugs are gapped at .025





Nothing else was really touched in the install process.
Smaay is offline   Reply With Quote
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Vortech Owner Thread & Setup Questions reyruiz191 Forced Induction 323 01-22-2020 10:10 PM
Edelbrock E-Force Supercharger itsibarra Forced Induction 936 09-27-2016 03:51 PM
Most annoyingly over-asked questions on FT86 forums mit_peid Off-Topic Lounge 36 01-16-2014 03:48 PM
Brz Info/Specs (helpful info for questions asked often) Gaen Subaru BRZ General Forum 0 05-24-2012 10:09 PM


All times are GMT -4. The time now is 12:27 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Garage vBulletin Plugins by Drive Thru Online, Inc.