follow ft86club on our blog, twitter or facebook.
FT86CLUB
Ft86Club
Delicious Tuning
Register Garage Members List Calendar Search Today's Posts Mark Forums Read

Go Back   Scion FR-S Forum | Subaru BRZ Forum | Toyota 86 GT 86 Forum | AS1 Forum - FT86CLUB > FT86CLUB Shared Forum > Regional Forums > Northwest

Northwest AK, ID, OR, WA


User Tag List

Reply
 
Thread Tools Search this Thread
Old 09-03-2018, 03:36 AM   #1
LeonardoDaVinny
NotVinnyy
 
Join Date: Jul 2018
Drives: 2013 White Pearl FRS
Location: Portland, OR
Posts: 34
Thanks: 17
Thanked 6 Times in 3 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Urgent Springs Install Help! PDX

Hi everyone. So I just tried to install some lowering springs and am very frustrated. I have been struggling for 8 hours trying to get the first strut back and it does not seem like anything is lining up. I have gone through the forums/youtube and followed the steps, but it is not working out. This is my first time doing anything like this on a vehicle, so it would be much appreciated if anyone is able to come assist me today, September 3rd. Any time is great.
The car is still disassembled as of now. I need it back together by Tuesday! I live in the NE Portland area. If anyoneís down to help out please send me a message @Leonardoda_vinny on IG. I am willing to compensate for your time, thanks!!!
LeonardoDaVinny is offline   Reply With Quote
Old 09-03-2018, 04:53 AM   #2
swarb
Senior Member
 
Join Date: Sep 2014
Drives: BRZ
Location: Los Angeles
Posts: 3,053
Thanks: 1,773
Thanked 2,447 Times in 1,271 Posts
Mentioned: 79 Post(s)
Tagged: 0 Thread(s)
Try the other strut, they are corner specific in the front. Otherwise pics could help.
swarb is offline   Reply With Quote
The Following User Says Thank You to swarb For This Useful Post:
Leonardo (09-03-2018)
Old 09-03-2018, 09:38 AM   #3
Yoshoobaroo
Torque BuffaloChicken Dip
 
Yoshoobaroo's Avatar
 
Join Date: Mar 2016
Drives: 2013 BRZ
Location: Florida
Posts: 1,275
Thanks: 609
Thanked 869 Times in 486 Posts
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Garage
Post some pictures of where it's not lining up, that way those of us who are 2000 miles away can try to help too
__________________
Yoshoobaroo is offline   Reply With Quote
Old 09-03-2018, 10:52 AM   #4
Leonardo
Row Row Row Your Boat!
 
Leonardo's Avatar
 
Join Date: Jul 2012
Drives: 13' FR-S, 07' MDX, 06' Ridgeline,
Location: EUGENE
Posts: 4,480
Thanks: 5,236
Thanked 3,959 Times in 2,176 Posts
Mentioned: 40 Post(s)
Tagged: 1 Thread(s)
I got a message that I was mentioned in this thread. I see that's not really the case...

Leo, Did you use the DIY? It really helped me when I lowered my car. It has lots of useful pics.

http://www.ft86club.com/forums/showthread.php?t=10842
__________________
<img src=https://www.ft86club.com/forums/picture.php?albumid=2239&pictureid=11508 border=0 alt= />


Life is but a Dream!
Leonardo is offline   Reply With Quote
Old 09-03-2018, 01:19 PM   #5
LeonardoDaVinny
NotVinnyy
 
Join Date: Jul 2018
Drives: 2013 White Pearl FRS
Location: Portland, OR
Posts: 34
Thanks: 17
Thanked 6 Times in 3 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by Leonardo View Post
I got a message that I was mentioned in this thread. I see that's not really the case...

Leo, Did you use the DIY? It really helped me when I lowered my car. It has lots of useful pics.

http://www.ft86club.com/forums/showthread.php?t=10842
I used DarrenDrivenís DIY as well as youtube vids.
LeonardoDaVinny is offline   Reply With Quote
Old 09-03-2018, 01:20 PM   #6
LeonardoDaVinny
NotVinnyy
 
Join Date: Jul 2018
Drives: 2013 White Pearl FRS
Location: Portland, OR
Posts: 34
Thanks: 17
Thanked 6 Times in 3 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by swarb View Post
Try the other strut, they are corner specific in the front. Otherwise pics could help.
I am still stuck on the driverís side. I will post pictures soon. So far, only the passenger and driverís side have been lifted up, but only the the driverís side strut was taken out and replaced with the new springs.
LeonardoDaVinny is offline   Reply With Quote
Old 09-03-2018, 01:21 PM   #7
LeonardoDaVinny
NotVinnyy
 
Join Date: Jul 2018
Drives: 2013 White Pearl FRS
Location: Portland, OR
Posts: 34
Thanks: 17
Thanked 6 Times in 3 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by Yoshoobaroo View Post
Post some pictures of where it's not lining up, that way those of us who are 2000 miles away can try to help too
Basically, when I install the strut back to the top, I can push the hub back into it, but the endlink (?) is short by a few inches. Photos will be coming asap. Thanks !
LeonardoDaVinny is offline   Reply With Quote
Old 09-03-2018, 01:29 PM   #8
Yoshoobaroo
Torque BuffaloChicken Dip
 
Yoshoobaroo's Avatar
 
Join Date: Mar 2016
Drives: 2013 BRZ
Location: Florida
Posts: 1,275
Thanks: 609
Thanked 869 Times in 486 Posts
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Garage
Quote:
Originally Posted by LeonardoDaVinny View Post
Basically, when I install the strut back to the top, I can push the hub back into it, but the endlink (?) is short by a few inches. Photos will be coming asap. Thanks !


That's cause the other side is pulling on the sway bar. Get the other side in, then they'll be even and you can hook the endlinks back up.
__________________
Yoshoobaroo is offline   Reply With Quote
Old 09-03-2018, 01:38 PM   #9
LeonardoDaVinny
NotVinnyy
 
Join Date: Jul 2018
Drives: 2013 White Pearl FRS
Location: Portland, OR
Posts: 34
Thanks: 17
Thanked 6 Times in 3 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by Yoshoobaroo View Post
That's cause the other side is pulling on the sway bar. Get the other side in, then they'll be even and you can hook the endlinks back up.
The passenger side is still hanging with the decompressed springs, but not completely removed yet. It is just unscrewed on the tophat, so once I remove all the bolts, it will come out. Youíre saying to remove the passenger side as well and then re-install it?
LeonardoDaVinny is offline   Reply With Quote
Old 09-03-2018, 02:32 PM   #10
LeonardoDaVinny
NotVinnyy
 
Join Date: Jul 2018
Drives: 2013 White Pearl FRS
Location: Portland, OR
Posts: 34
Thanks: 17
Thanked 6 Times in 3 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by Yoshoobaroo View Post
Post some pictures of where it's not lining up, that way those of us who are 2000 miles away can try to help too
Name:  spring install.jpg
Views: 107
Size:  67.9 KB
LeonardoDaVinny is offline   Reply With Quote
Old 09-03-2018, 02:39 PM   #11
n0thing
Senior Member
 
Join Date: Jan 2014
Drives: Subaru BRZ
Location: Markham
Posts: 392
Thanks: 48
Thanked 90 Times in 53 Posts
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Push the knuckle down and insert bolts?
n0thing is offline   Reply With Quote
Old 09-03-2018, 02:49 PM   #12
LeonardoDaVinny
NotVinnyy
 
Join Date: Jul 2018
Drives: 2013 White Pearl FRS
Location: Portland, OR
Posts: 34
Thanks: 17
Thanked 6 Times in 3 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by n0thing View Post
Push the knuckle down and insert bolts?
Thats as far as it goes
LeonardoDaVinny is offline   Reply With Quote
Old 09-03-2018, 02:53 PM   #13
Yoshoobaroo
Torque BuffaloChicken Dip
 
Yoshoobaroo's Avatar
 
Join Date: Mar 2016
Drives: 2013 BRZ
Location: Florida
Posts: 1,275
Thanks: 609
Thanked 869 Times in 486 Posts
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Garage
Undo the sway bar link, bolt the knuckle up, do the other side, reattach the sway bar.
__________________
Yoshoobaroo is offline   Reply With Quote
Old 09-03-2018, 02:53 PM   #14
SuperTom
Senior Member
 
SuperTom's Avatar
 
Join Date: Feb 2014
Drives: C5 Corvette, '17 Toyota 86, Jeep XJ
Location: New Castle DE
Posts: 1,162
Thanks: 642
Thanked 598 Times in 370 Posts
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Lesson learned to always allow extra time and do more research before doing mods. Your in a rush and probably overlooking something easy. Pic you posted doesn't work for me. Good luck!
SuperTom is offline   Reply With Quote
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Urgent help requested on exhaust install Vdub Engine, Exhaust, Transmission 8 05-20-2017 09:13 PM
new springs install help Bigedb Arizona 4 03-13-2015 08:08 PM
First time Springs Install... Help please VakaGT Suspension | Chassis | Brakes -- Sponsored by 949 Racing 7 11-28-2014 09:58 PM
Install new springs? Intake Northern California 3 10-05-2013 01:55 PM
How much should it be to install springs? MiniGuy CANADA 28 05-07-2013 09:44 AM


All times are GMT -4. The time now is 09:00 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Garage vBulletin Plugins by Drive Thru Online, Inc.